
  



<!DOCTYPE html>
        <html lang="en" class="no-js not-nowapp">
        <head>
<base href="https://www.stltoday.com/content/tncms/live/" />
<meta name="tncms-access-version" content="2022-12-02 19:53:51" />
<meta name="tncms-access-criteria" content="{&quot;0bb6d666-7868-11ec-8a86-8378c6237a04&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;00f3c388-7868-11ec-8a86-53ee97ff872d&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;],&quot;f29eeee8-7867-11ec-8a86-b32b52305145&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;1d7337de-32b0-11ed-8a86-ab311cb11364&quot;:[],&quot;4ef56d66-786d-11ec-8a86-7ff9cd4d035c&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;47def326-7acf-11ec-8a86-d764f6e0537c&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;],&quot;3e62a522-786d-11ec-8a86-43c2739f49b4&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;30a0ec5a-786d-11ec-8a86-bbdda5813ee4&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;1d3050ca-786d-11ec-8a86-87a99f96e49d&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;d199d40e-7869-11ec-8a86-ab13ecd9410b&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;],&quot;52b5489a-803d-11ec-8a86-3f176629afaf&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;],&quot;a55a66d8-7869-11ec-8a86-1b3d9ff75525&quot;:[&quot;e2e729c8-7864-11ec-8a86-27ed95941cc0&quot;,&quot;ea4e485e-7864-11ec-8a86-a7545e759aea&quot;]}" />
<meta name="tncms-criteria-ids" content="e2e729c8-7864-11ec-8a86-27ed95941cc0,ea4e485e-7864-11ec-8a86-a7545e759aea" />
<meta name="tncms-access-asset-app" content="editorial" />
<meta name="tncms-access-asset-id" content="f6aec1ca-8248-11ed-b39f-0362ef716cce" />
<meta name="keywords" content="prep-sports, meet, finish, sport" />
<meta name="news_keywords" content="prep-sports, meet, finish, sport" />
<meta name="description" content="Finished no lower than seventh place in eight meets in her first season, capped by a seventh-place showing in Class 5 state meet that helped Chargers finish fourth in team" />
<meta name="author" content="Paul Halfacre" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=502878743" />
<meta name="robots" content="max-image-preview:standard" />
<meta name="google-site-verification" content="12rz05kDwbkVAa130rtU9vbSU7FOIg-6nYwFTGmFmw8" />
<meta name="bitly-verification" content="fbb83c3def2d" />
<meta name="y_key" content="PRah6gnV34E7FNluCkd0BOm4bVhTShpfdHje8j8ERnO4zik1QdfubwS2da8_bXeYow--" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/4ce82390-59b2-11e6-a3c5-b77ec6e8d16d.png?crop=375%2C375%2C30%2C0&amp;resize=200%2C200&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="200" />
<meta property="og:title" content="Mary McKenzie, freshman, Cor Jesu" />
<meta property="og:description" content="Finished no lower than seventh place in eight meets in her first season, capped by a seventh-place showing in Class 5 state meet that helped Chargers finish fourth in team" />
<meta property="og:site_name" content="STLtoday.com" />
<meta property="og:section" content="All-Metro Girls Cross Country" />
<meta property="fb:app_id" content="205112096200104" />
<meta property="article:publisher" content="https://www.facebook.com/STLPD" />
<meta name="twitter:image" content="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/4ce82390-59b2-11e6-a3c5-b77ec6e8d16d.png?crop=375%2C375%2C30%2C0&amp;resize=200%2C200&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@STLhssports" />
<meta name="twitter:creator" content="@https://twitter.com/pHalfacre_STL" />
<link rel="manifest" href="/tncms/messaging/manifest/" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.d655407c2beee1a5e5788ed5c20be9d9.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.96c1f8e83067984298cdd09c5b707c89.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/styles/lee.ds.css?_dc=1671747505"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-notification-controls.e115619c5ab5d4eb38fbd29cc0d2ea9b.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/site/resources/styles/stl.dsv3.css?_dc=1643659011"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_subscription/resources/styles/lee-subscription-list-v2.css?_dc=1671692428"/>
<style>/*<![CDATA[*/ .follow-links-1245402 li { margin-right: 1px; padding: 0; } .follow-links-1245402 li a, .follow-links-1245402 li a:focus, .follow-links-1245402 li a:active { ; font-size: 18px; margin-right: 10px; padding:0; box-shadow: none; } .follow-links-1245402 li a:hover { text-decoration: none; } .follow-links-1245402 li a.fb,.follow-links-1245402 li a.fb:hover { color: #3A59A5; } .follow-links-1245402 li a.tw,.follow-links-1245402 li a.tw:hover { color: #46C8F9; } .follow-links-1245402 li a.yt,.follow-links-1245402 li a.yt:hover { color: #CE2B29; } .follow-links-1245402 li a.pt,.follow-links-1245402 li a.pt:hover { color: #D22D2B; } .follow-links-1245402 li a.is,.follow-links-1245402 li a.is:hover { color: #D4C4A2; } .follow-links-1245402 li a.li,.follow-links-1245402 li a.li:hover { color: #1B86BC; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"page":{"canonical_url":"https:\/\/www.stltoday.com\/sports\/high-school\/all-metro\/girls-cross-country\/mary-mckenzie-freshman-cor-jesu\/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"},"content":{"id":"f6aec1ca-8248-11ed-b39f-0362ef716cce","title":"Mary McKenzie, freshman, Cor Jesu","type":"article","published_time":"2022-12-22T22:50:00Z","tags":["#slsa-allmetro-f22","#slsa-allmetro-thirdteam-f22","#slsa-allmetro","#slsa-allmetro-thirdteam","#slsa-exclude","prep-sports","meet","finish","sport"],"authors":[{"id":"fa4aa9be-ce14-11e6-b397-db2e5928c384","eh":"ea8b1c1177d40f70545032b7d35e92cf0c10b3033809c356e05ab7d77c8ca906","first_name":"Paul","last_name":"Halfacre","title":null}],"taxnonomies":{"blox_sections":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/section","items":["sports\/high-school\/all-metro\/girls-cross-country","sports\/high-school\/all-metro","sports\/high-school","sports\/high-school\/girls-cross-country"]},"blox_flags":{"ns":"https:\/\/www.townnews.com\/ns\/blox\/v1\/tags\/flag","items":[]}},"metrics":{"image_count":0,"video_count":0,"audio_count":0,"word_count":47},"byline":"By Paul Halfacre | STLhighschoolsports.com\n"},"product":{"version":"1.65.4"},"crm":{"group_id":"35"}},"tncms":{"asset":{"id":"f6aec1ca-8248-11ed-b39f-0362ef716cce","app":"editorial","ga_page":"\/sports\/high-school\/all-metro\/girls-cross-country\/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"},"page":{"app":"editorial","skin":"flex-editorial","theme":"flex","http_status":200},"client":{"is_bot":"no","noscript":false,"is_gdpr":"no"},"system":{"render_time":293}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/6894/cc.js?ns=_cc6894" id="LOTCC_6894"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6894.add('tp', 'TNNW');
		_cc6894.add('act', ' User Login');
		_cc6894.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc6894.bcp();
</script>

<script>/*<![CDATA[*/ window.tncms_access_control_sync = true; /*]]>*/</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script>/*<![CDATA[*/ window.TNCMS = window.TNCMS || {};window.TNCMS.Access = window.TNCMS.Access || [];(function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } console.debug('TNCMS.DMP: Audience session storage found for lotame'); callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } console.debug('TNCMS.DMP: waiting for lotame script to pull audiences'); oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); console.debug('TNCMS.DMP: audiences loaded for lotame'); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=6881/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 6881, provider: 'lotame' } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(function(aAudiences) { window.TNCMS.Access.push(function() { TNCMS.Access.setAudiences(aAudiences); });}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.LEE_DS_V3 = true;window.assetUUID = 'f6aec1ca-8248-11ed-b39f-0362ef716cce'; /*]]>*/</script>
<script src="https://cmp.osano.com/16CVqQSid6k3038vU/fef0f8b2-698d-45ee-89c5-d8fbf51fbfb7/osano.js"></script>
<script>/*<![CDATA[*/ (function(g,i,z,m,o,e,s){z=window;m=document;o='script';z[g]=z[g]||function(c){z[g].cmds=z[g].cmds||[];z[g].cmds.push(c)};
    z[g].cmds=z[g].cmds||[];e=m.createElement(o);r=new URL(i,m.location);r.hash=g;z[g][o]=e;e.src=r;m.head.appendChild(e);
    })("__STL","https:\/\/bloximages.newyork1.vip.townnews.com\/stltoday.com\/content\/tncms\/live\/libraries\/flex\/components\/site\/resources\/scripts\/main.js?_dc=1629146859"); /*]]>*/</script>
<script>/*<![CDATA[*/ __STL(function(me) {
    me.register('site/jose',"https:\/\/bloximages.newyork1.vip.townnews.com\/stltoday.com\/content\/tncms\/live\/libraries\/flex\/components\/site\/resources\/scripts\/jose.js?_dc=1629146443");    
    me.register('site/stl.init',"https:\/\/bloximages.newyork1.vip.townnews.com\/stltoday.com\/content\/tncms\/live\/libraries\/flex\/components\/site\/resources\/scripts\/stl.init.js?_dc=1648053941");    
}); /*]]>*/</script>
<script>/*<![CDATA[*/ __STL(function(me){me.require(['site/stl.init'],function(me){console.dir(me);
me.domain="stltoday.com";me.page = __STL.page || {};me.page.venue="app";me.page.mode='live';me.page.app="editorial";me.page.map="lee-ds-v3";me.page.type="article";me.page.tags=__STL.page.tags||{};me.page.tags.k={"prep-sports":"prep-sports","meet":"meet","finish":"finish","sport":"sport"};me.page.path="\/sports\/high-school\/all-metro\/girls-cross-country";me.page.base_url="https:\/\/www.stltoday.com\/content\/tncms\/live\/";me.page.code=200;me.page.admin_edit_url="https:\/\/www.stltoday.com\/tncms\/admin\/editorial-asset\/?edit=f6aec1ca-8248-11ed-b39f-0362ef716cce";me.meter={"src":"url","mode":"custom"};me.sub_services=[{"id":"2373","level":"DOB"},{"id":"2505","level":"LEE"},{"id":"2438","level":"EMPL"}];__STL.services_check(me.sub_services);})}); /*]]>*/</script>
<script>/*<![CDATA[*/ __STL(function(me) {
    me.register('docCookies',"https:\/\/bloximages.newyork1.vip.townnews.com\/stltoday.com\/content\/tncms\/live\/libraries\/flex\/components\/site\/resources\/scripts\/docCookies.js?_dc=1628277801");
    me.register('user',"https:\/\/bloximages.newyork1.vip.townnews.com\/stltoday.com\/content\/tncms\/live\/libraries\/flex\/components\/site\/resources\/scripts\/user.js?_dc=1628288341");
}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.7b5fd2a1aa906214ae39b25cd6ec9283.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.ef1ae2cf9d9803199a19b009dc464018.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/leetemplates.com/content/tncms/live/global/resources/scripts/falcon/stltoday.com.js?_dc=122217"></script>
<script>/*<![CDATA[*/ var __tnt = __tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.slots = __tnt.ads.dfp.slots || {};
    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["prep-sports","meet","finish","sport"];

    __tnt.ads.dfp.refresh = true;
    __tnt.ads.dfp.targeting.sub = (__tnt.user.loggedIn && __tnt.user.services) ? 'yes' : 'no';  
    if(window.localStorage){
        if(window.localStorage.getItem('_us_master_id') || __tnt.user.loggedIn){
            __tnt.ads.dfp.ppid = window.localStorage.getItem('_us_master_id') || window.sessionStorage.getItem('lee_uuid');
            jQuery('<style>.ads-dfp-ppid { display:none; }</style>').appendTo('head');
        }
    }
    
    __tnt.ads.dfp.targeting.page=["asset","article","app-editorial"];
    if( typeof window.I10C != 'undefined' && typeof window.I10C.Morph != 'undefined' ){
        __tnt.ads.dfp.targeting.page.push('recover');
    }
    
    __tnt.docWidth = window.innerWidth;
    if( __tnt.docWidth > 1899 ){ 
        __tnt.docWidthBreakPoint = 'xl_screen';
    } else if ( __tnt.docWidth > 1619 ){
        __tnt.docWidthBreakPoint = 'lg_screen';
    } else if ( __tnt.docWidth > 991 ){
        __tnt.docWidthBreakPoint = 'md_screen';
    } else if ( __tnt.docWidth > 767 ){
        __tnt.docWidthBreakPoint = 'sm_screen';
    } else {
        __tnt.docWidthBreakPoint = 'xs_screen';
    }
    __tnt.ads.dfp.targeting.page.push(__tnt.docWidthBreakPoint);

    __tnt.ads.dfp.targeting.browser = __tnt.client.browser.name;
    
    window.googletag = window.googletag || {};
    window.googletag.cmd = window.googletag.cmd || [];
    window.PBJS_dfp_ads = [];
    
    (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })(); /*]]>*/</script>
<script src="https://c.amazon-adsystem.com/aax2/apstag.js"></script>
<script>/*<![CDATA[*/ window.APS_dfp_ads = [];
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},dpa:function(){q("di",arguments)},rpa:function(){q("ri",arguments)},upa:function(){q("ui",arguments)},_Q:[]};}("apstag",window);
    apstag.init({
        pubID: '3266',
        adServer: 'googletag',
        params: {
            sections: 'sports'
        }
    });
    
    
    if(TNCMS.User && TNCMS.User.isLoggedIn()){
        var amzHash = TNCMS.User.getClaim('user', 'eml').sha256;
        if(amzHash){
            var amzToken = {
                'hashedRecords': [{
                    'type': 'email',
                    'record': amzHash
                }]
            };
            apstag.rpa(amzToken, function(){
                __tnt.log('Set A9 hash');
            });
        }
    }
     /*]]>*/</script>
<script>/*<![CDATA[*/ window.MSInputMethodContext && document.documentMode && document.write('<script src="https://cdn.jsdelivr.net/npm/css-vars-ponyfill@2"><\/script>');
    window.MSInputMethodContext && document.documentMode && window.addEventListener('load', function() { cssVars({ include:'style,link[href*="lee.ds.css"]' })}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script>/*<![CDATA[*/ dataLayer.push({"mobile_ad_breaks":0,"tablet_ad_breaks":0,"desktop_ad_breaks":0}); /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.a814fe612f2dcba9061edc229aeaf90b.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.panel.bacbeac9a1ca6ee75b79b21a0e2e99f2.js"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-app.js" defer="defer"></script>
<script src="https://www.gstatic.com/firebasejs/6.6.2/firebase-messaging.js" defer="defer"></script>
<script src="/shared-content/art/tncms/api/messaging.js" defer="defer"></script>
<script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded', function() {TNCMS.Messaging.init({messagingSenderId: '316160268898'});TNCMS.Messaging.onMessage(messagingCallback);}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/prebid7.9.0.js?_dc=1671001230"></script>
<script>/*<![CDATA[*/ document.addEventListener('TownnewsSegmentLoaded', async function(oEvent) {
    try {
        console.log('Checking to see if the user needs to have a meter patch');
        
        if (window.localStorage.getItem('patchMeter')) {
            console.log('User already patched');
            return;
        }

        const oUser = window.analytics.user();
        if (!oUser) {
            throw new Exception('No segment user returned');
        }

        const oResult = await window.fetch('/tncms/dmp/segment_audiences/?anonymous_id=' + encodeURIComponent(oUser.anonymousId()), {
            method: 'GET',
            headers: {
                'Accept': 'application/json'
            }
        });

        const oJSON = await oResult.json();
        const oSearch = oJSON.audiences.find(oEl => {
            return oEl.id && oEl.id === 'non_subscriber_content_cap_in_last_45_days';
        });

        if (!oSearch) {
            window.localStorage.setItem('patchMeter', true);
            console.log('Not found in the 45 day content user audience');
            return;
        }

        const oCookies = Object.fromEntries(document.cookie.split('; ').map(c => c.split('=')));
        for (const [sKey, xValue] of Object.entries(oCookies)) {
            if (sKey.indexOf('tncms:meter:assets') === 0) {
                let oExpires = new Date();
                oExpires.setDate(oExpires.getDate() + Math.floor(Math.random() * 4) + 6);
                document.cookie = sKey + '=100000; expires=' + oExpires.toGMTString() + '; path=/; SameSite=Strict';
            }
        };

        window.localStorage.setItem('patchMeter', true);
    } catch(oError) {
        console.log('Patch Meter Error', oError);
    } 
}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/scripts/lee.common.js?_dc=1671747506"></script>

            
            <title>Mary McKenzie, freshman, Cor Jesu</title>
            
    <style>:root { --lee-blox-link-color: #2a5caa; --lee-blox-link-color-light: #89ABE1; --lee-blox-accent-color: #2E589B; --lee-blox-accent-color-secondary: #21314A; --lee-blox-masthead-color: #090E15; --lee-blox-nav-color: #000000; } .osano-cm-widget { display: none; } /** begin: site specific styles */ /** end: site specific styles */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.stltoday.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/b8a0baa4-7690-11e9-b049-9b352dba21d9.jpg?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    
        <link rel="preconnect" href="https://trinitymedia.ai">
    
        <link rel="preconnect" href="https://vd.trinitymedia.ai">
    <link rel="alternate" type="application/rss+xml" title="Mary McKenzie, freshman, Cor Jesu" href="http://www.stltoday.com/search/?f=rss&amp;t=article&amp;c=sports/high-school/all-metro/girls-cross-country&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a7c71fa5a63ad1158170fb2c085be042.js"></script>
            
        </head>
        <body class="fixed-scroll-nav app-editorial grid-custom blox-asset uuid-f6aec1ca-8248-11ed-b39f-0362ef716cce  section-sports section-high-school section-all-metro section-girls-cross-country type-article infinity-summary-siderail" data-authors='[]' data-path="/sports/high-school/all-metro/girls-cross-country">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.stltoday.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.page.canonical_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html&amp;townnews.content.id=f6aec1ca-8248-11ed-b39f-0362ef716cce&amp;townnews.content.title=Mary+McKenzie%2C+freshman%2C+Cor+Jesu&amp;townnews.content.type=article&amp;townnews.content.published_time=2022-12-22T22%3A50%3A00Z&amp;townnews.content.tags.0=%23slsa-allmetro-f22&amp;townnews.content.tags.1=%23slsa-allmetro-thirdteam-f22&amp;townnews.content.tags.2=%23slsa-allmetro&amp;townnews.content.tags.3=%23slsa-allmetro-thirdteam&amp;townnews.content.tags.4=%23slsa-exclude&amp;townnews.content.tags.5=prep-sports&amp;townnews.content.tags.6=meet&amp;townnews.content.tags.7=finish&amp;townnews.content.tags.8=sport&amp;townnews.content.authors.0.id=fa4aa9be-ce14-11e6-b397-db2e5928c384&amp;townnews.content.authors.0.eh=ea8b1c1177d40f70545032b7d35e92cf0c10b3033809c356e05ab7d77c8ca906&amp;townnews.content.authors.0.first_name=Paul&amp;townnews.content.authors.0.last_name=Halfacre&amp;townnews.content.taxnonomies.blox_sections.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fsection&amp;townnews.content.taxnonomies.blox_sections.items.0=sports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country&amp;townnews.content.taxnonomies.blox_sections.items.1=sports%2Fhigh-school%2Fall-metro&amp;townnews.content.taxnonomies.blox_sections.items.2=sports%2Fhigh-school&amp;townnews.content.taxnonomies.blox_sections.items.3=sports%2Fhigh-school%2Fgirls-cross-country&amp;townnews.content.taxnonomies.blox_flags.ns=https%3A%2F%2Fwww.townnews.com%2Fns%2Fblox%2Fv1%2Ftags%2Fflag&amp;townnews.content.metrics.image_count=0&amp;townnews.content.metrics.video_count=0&amp;townnews.content.metrics.audio_count=0&amp;townnews.content.metrics.word_count=47&amp;townnews.content.byline=By+Paul+Halfacre+%7C+STLhighschoolsports.com%0A&amp;townnews.product.version=1.65.4&amp;townnews.crm.group_id=35&amp;tncms.asset.id=f6aec1ca-8248-11ed-b39f-0362ef716cce&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html&amp;tncms.page.app=editorial&amp;tncms.page.skin=flex-editorial&amp;tncms.page.theme=flex&amp;tncms.page.http_status=200&amp;tncms.client.is_bot=no&amp;tncms.client.noscript=yes&amp;tncms.client.is_gdpr=no&amp;tncms.system.render_time=293" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><a href="http://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html#main-page-container" class="sr-only sr-only-focusable">Skip to main content</a><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
    <script>
        var dataLayer = window.dataLayer || [];
        dataLayer.push({"ga_ua":"UA-54716522-2","ga_ua_local":"UA-26472327-1","adroll_adv":"OISRCTP2N5CE5GW2ESJAH6","adroll_pix":"ZBBF4EWMKBEQDBWNF5BNZC","taxonomy_1":"sports","taxonomy_2":"high-school","taxonomy_3":"all-metro","taxonomy_4":"girls-cross-country","taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"stltoday.com","blox_skin":"flex-editorial","blox_application":"editorial","blox_template_version":"dsv3","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"sports","blox_sections":"sports,high-school,all-metro,girls-cross-country","weather_temp":4,"weather_conditions":"Light Snow\/Wind","asset_source":"local","source_app":"editorial","blox_asset_type":"article","asset_section":"sports\/high-school\/all-metro\/girls-cross-country","asset_sections":"sports\/high-school\/all-metro\/girls-cross-country,sports\/high-school\/all-metro,sports\/high-school,sports\/high-school\/girls-cross-country","asset_id":"f6aec1ca-8248-11ed-b39f-0362ef716cce","asset_headline":"Mary McKenzie, freshman, Cor Jesu","asset_byline":"By Paul Halfacre | STLhighschoolsports.com","asset_authors":"Paul Halfacre","asset_pub_date":"12\/22\/2022","asset_pub_time":"4:50 pm","asset_pub_iso8601":"2022-12-22T16:50:00-06:00","asset_canonical":"https:\/\/www.stltoday.com\/sports\/high-school\/all-metro\/girls-cross-country\/mary-mckenzie-freshman-cor-jesu\/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html","asset_content_length":273,"asset_related_length":0,"asset_has_video":"no","asset_tag_1":"prep-sports","asset_tag_2":"meet","asset_tag_3":"finish","asset_tag_4":"sport","asset_has_paywall":"no","subscription_max_views":3});

        
        var sUserUUID = false;
        var sUserPPID = false;
        if(__tnt.user.loggedIn && window.sessionStorage){ 
            var sUserUUID = window.sessionStorage.getItem('lee_uuid');
            if(!sUserUUID){
                sUserUUID = getUserToken().sub;
                window.sessionStorage.setItem('lee_uuid', sUserUUID);
            }
        }
        if(window.localStorage){ var sUserPPID = window.localStorage.getItem('_us_master_id'); }
        dataLayer.push(
            {'user_id': __tnt.user.screenName},
            {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
            {'user_subscription': __tnt.user.services ? 'Yes' : 'No'},
            {'user_uuid': sUserUUID},
            {'user_ppid': sUserPPID},
            {'utm_label': __tnt.urlHash('utm_label')}
        );
        
        
        if(__tnt.user.services){
            var falcon_sub_name = Cookies.get('leefalcon_membership');
            dataLayer.push({
                'tncms': {
                    'subscription': {
                        'falcon_service': falcon_sub_name ? falcon_sub_name : '',
                        'user_service_ids': __tnt.user.services
                    }
                }
            });
            
            var lee_clus = Cookies.get('lee-clus');
            if(!lee_clus){
                if(typeof Storage !== 'undefined'){
                    var lee_ulli = new Date().toLocaleString('en-us', {year: 'numeric', month: '2-digit', day: '2-digit'}).replace(/(\d+)\/(\d+)\/(\d+)/, '$3$1$2');
                    window.localStorage.setItem('lee_ulld', lee_ulli);
                    var lee_ulld_iso8601 = new Date().toISOString();
                    window.localStorage.setItem('lee_ulld_iso8601', lee_ulld_iso8601);
                }
                var lee_clus = Cookies.set('lee-clus', 'true', {path:'/'});
            }
        }
        
        if(typeof Storage !== 'undefined'){
            var lee_glus = window.localStorage.getItem('lee_ulld');
            if(lee_glus){
                // IE hack
                if(lee_glus.match('/')){
                    var lee_glusIE = lee_glus.split('/');
                    lee_glus = lee_glusIE[2]+lee_glusIE[0]+lee_glusIE[1];
                }
                dataLayer.push({'sub_last_login': lee_glus});
            }
            var sub_last_login_iso8601 = window.localStorage.getItem('lee_ulld_iso8601');
            if(sub_last_login_iso8601){
                dataLayer.push({'sub_last_login_iso8601': sub_last_login_iso8601});
            }
        }
    </script>
    <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TDWDC2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script>
        (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-TDWDC2');
    </script>

    <script>
        __tnt.googleEvent = function(obj) {
            dataLayer.push({
                'event': 'gaTriggerEvent',
                'gaEventCategory': obj.category,
                'gaEventAction': obj.action,
                'gaEventLabel': obj.label,
                'gaEventValue': obj.value
            });
        }
        __tnt.googleSocial = function(obj) {
            dataLayer.push({
                'event': 'socialEvent',
                'socialNetwork': obj.network,
                'socialAction': obj.socialAction,
                'socialTarget': obj.url
            });
        }
        __tnt.googlePageView = function(obj) {
            var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
            dataLayer.push({
                'event': 'VirtualPageview',
                'virtualPageURL': sURL,
                'virtualPageTitle': obj.title
            });
        }
    </script>
    <!-- End Google Tag Manager -->
        <!--{begin:opt_tagManagerAfter}-->
<!--{begin:AmpDigSTL-GTM}-->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NT9PLTF"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NT9PLTF');</script>
<!--{end:AmpDigSTL-GTM}--><!--{end:opt_tagManagerAfter}--><style>
        .player.floating .floatContainer { z-index: 1000!important; }
        #lee-registration-wall .dismiss-regwall,
        #lee-registration-wall .title span,
        #lee-registration-wall .lee-reg-content { display: none; }
        #lee-registration-wall .modal-content {
            box-shadow: 0px 7px 15px 1px rgba(0, 0, 0, 0.12);
            border: 1px solid rgba(0, 0, 0, 0.03);
            border-radius: 2px;
        }
        #lee-registration-wall .wall-header {
            background-color: var(--lee-blox-masthead-color);
            padding: 15px 20px;
            margin: -15px -15px 20px -15px;
        }
        #lee-registration-wall .wall-header div { display: inline; }
        #lee-registration-wall .modal-top .logo img {
            max-height: 35px;
            max-width: 220px;
        }
        #lee-registration-wall .dismiss-regwall { 
            color: #fff; 
            cursor: pointer; 
        }
        #lee-registration-wall .dismiss-regwall:hover { opacity: .7 }
        #lee-registration-wall .modal-top .title {
            font-size: 20px;
            line-height: 22px;
            margin-bottom: 10px;
            text-align: center;
            color: var(--lee-blox-accent-color);
        }
        #lee-registration-wall.login .modal-top .title { 
            margin-bottom: 20px;
            color: var(--lee-blox-accent-color-secondary);
        }
        #lee-registration-wall #lee-regwall-login-frame { 
            height: 500px; 
            padding: 0 10px; 
        }
        @media (min-width: 767px){
            #lee-registration-wall.login #lee-regwall-login-frame { height: 360px; }
            #lee-registration-wall.login .modal-dialog { width: 770px; }
        }
    </style>
    <div id="lee-registration-wall">
        <div id="lee-registration-wall-modal" class="modal fade hidden-print" tabindex="-1" role="dialog">
            <div class="modal-dialog" role="document">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-top">
                            <div class="wall-header">
                                <div class="logo">
                                    <a href="/"><img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></a>
                                </div>
                                <div class="pull-right">
                                    <a id="reg-wall-close-hard" class="dismiss-regwall" href="https://www.stltoday.com/users/signup/?referer_url=https%253A%252F%252Fwww.stltoday.com%252Fsports%252Fhigh-school%252Fall-metro%252Fgirls-cross-country%252Fmary-mckenzie-freshman-cor-jesu%252Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html#tracking-source=registration_wall"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 12 12" stroke="currentColor" stroke-width="1" stroke-linecap="round" width="24" height="24">
        <line x1="11" y1="1" x2="1" y2="11"></line>
        <line x1="1" y1="1" x2="11" y2="11"></line>
    </svg></a>
                                    <a id="reg-wall-close-soft" class="dismiss-regwall" data-dismiss="modal" aria-label="Close" style="display:block"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 12 12" stroke="currentColor" stroke-width="1" stroke-linecap="round" width="24" height="24">
        <line x1="11" y1="1" x2="1" y2="11"></line>
        <line x1="1" y1="1" x2="11" y2="11"></line>
    </svg></a>
                                </div>
                                <div class="clearfix"></div>
                            </div>
                            <div class="text-center title">
                                <span id="lee-reg-wall-title">Register for more free articles.</span>
                                <span id="lee-newsletter-title">Sign up for our newsletter to keep reading.</span>
                            </div>
                            <div class="lee-reg-content" id="regwall-login-frame">
                                <iframe id="lee-regwall-login-frame" src-set="https://www.stltoday.com/users/login/?referer_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html&modal_doc=true&regwall=true" frameborder="0" height="500" width="100%" scrolling="no"></iframe>
                            </div>
                            <div class="lee-reg-content" id="regwall-newsletter"><style>
            #pu-email-form-email-preps-article {
                clear: both;
                
                    background-color: #fff;
                
                
                
                    color: #222;
                
                background-position: bottom;
                background-repeat: no-repeat;
                padding: 15px 0 20px;
                margin-bottom: 40px;
                border-top: 4px solid rgba(0,0,0,.8);
                border-bottom: 1px solid rgba(0,0,0,.2);
                
            }
            #pu-email-form-email-preps-article,
            #pu-email-form-email-preps-article p {
                font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
            }
            #pu-email-form-email-preps-article h2 {
                font-size: 24px;
                margin: 15px 0 5px 0;
                font-family: "serif-ds", Times, "Times New Roman", serif; 
            }
            #pu-email-form-email-preps-article .lead { 
                margin-bottom: 5px; 
            }
            #pu-email-form-email-preps-article .email-desc {
                font-size: 16px;
                line-height: 20px;
                margin-bottom: 5px;
                opacity: 0.7;
            }
            #pu-email-form-email-preps-article form {
                padding: 10px 30px 5px 30px;
            }
            #pu-email-form-email-preps-article .disclaimer {
                opacity: 0.5;
                margin-bottom: 0;
                line-height: 100%;
            }
            #pu-email-form-email-preps-article .disclaimer a {
                color: #222;
                text-decoration: underline;
            }
            #pu-email-form-email-preps-article .email-hammer {
                
                    border-bottom: 3px solid #222;
                
                opacity: .5;
                display: inline-block;
                padding: 0 10px 5px 10px;
                margin-bottom: -5px;
                font-size: 16px;
            }
            @media (max-width: 991px) {
                #pu-email-form-email-preps-article form {
                    padding: 10px 0 5px 0;
                }
            }
        </style>
        <div id="pu-email-form-email-preps-article" class="p402_hide hidden-print"><div class="header-image margin-bottom">
                    <img class="img-responsive" src="https://www.stltoday.com/tncms/media/high_school_sports_header/" alt="">
                </div><div class="text-center"><p class="email-desc">STLHighSchoolSports.com is the most comprehensive source of stats, scores and stories from any and all area high schools.</p></div>

            <div id="email-error-email-preps-article" class="alert alert-danger text-center margin-top" role="alert" style="display:none"></div>
            <div id="email-success-email-preps-article" class="alert alert-success text-center margin-top" role="alert" style="display:none"></div>

            <form class="pu-form" action="https://leeaws.com/postup/subscribe/" method="post" target="_blank">
                <input name="return" type="hidden" value="https://stltoday.com/newsletters/thank-you/#tracking-source=preps&ir=true">
                <input id="pu-list-email-preps-article" name="subscribe[]" type="hidden" value="874">
                <input class="hide" id="hp-email-preps-article" name="phone" type="text">
                
                <div class="form-group">
                    <div class="input-group email-input ">
                        <input id="pu-email-email-preps-article" type="email" name="email" class="form-control" required placeholder="Email Address">
                        <span class="input-group-btn">
                            <button id="pu-btn-email-preps-article" type="submit" class="btn btn-primary">Sign up!</button>
                        </span>
                    </div>
                </div>
                <div id="x-email-lists"></div>
                <div class="disclaimer text-center">
                    
                        <small>* I understand and agree that registration on or use of this site constitutes agreement to its user agreement and <a href="/privacy/" target="_blank">privacy policy</a>.</small>
                    
                </div>
                
            </form> 
        </div>
        <script>
            jQuery(document).ready(function($){
                
                $('#pu-email-form-email-preps-article .pu-form').submit(function(e){
                    if( $('#hp-email-preps-article').val() === '') {
                        $('#hp-email-preps-article').attr('disabled', 'disabled');
                        $('#pu-btn-email-preps-article').attr('disabled', 'disabled');
                        $.ajax({  
                            type: 'GET',        
                            url: 'https://leeaws.com/postup/subscribe/',
                            data: {
                                'subscribe[]': $('#pu-list-email-preps-article').val(),
                                'email': $('#pu-email-email-preps-article').val(),
                                'notify': Cookies.get('lee_pu_notify') ? '' : 'true',
                            }, 
                            dataType: 'jsonp'
                            
                        }).done(function(result){
                            if (result.status && result.status === 'error') {
                                $('#email-error-email-preps-article').html('<strong>An error occured.</strong><br>' + result.data.message).fadeIn();
                                $('#pu-btn-email-preps-article').attr('disabled', false);
                                
                            } else if(result.subscribed) {
                                $('#email-success-email-preps-article').html('<strong>Thank you!</strong><br>' + result.email + ' has been subscribed.').fadeIn();
                                $('#pu-email-form-email-preps-article .pu-form').fadeOut();
                                Cookies.set('lee_pu_notify', 'true', {path:'/'});
                                
                                __tnt.trackEvent({
                                    'category': 'newsletter-widget',
                                    'action': 'submit',
                                    'label': 'email-preps-article',
                                    'value': 1
                               });
                            }
                            
                        }).fail(function(){
                            $('#email-error-email-preps-article').html('<strong>An error occured.</strong><br> Please try again later').fadeIn();
                            $('#pu-btn-email-preps-article').attr('disabled', false);
                        });
                        
                        e.preventDefault();
                    }
                    return false;
                });
            });
        </script></div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div><style>
        .modal-backdrop.in {
            filter: alpha(opacity=90);
            opacity: .9;
            background-color: #fff;
        }
        #lee-services-modal .modal-content {
            box-shadow: 0px 7px 15px 1px rgba(0, 0, 0, 0.12);
            border: 1px solid rgba(0, 0, 0, 0.03);
            border-radius: 2px;
        }
            #lee-services-modal .wall-header {
                background-color: var(--lee-blox-masthead-color);
                padding: 15px 20px;
                margin: -15px -15px 20px -15px;
            }
            #lee-services-modal .wall-header div { 
                display: inline; 
            }
            #lee-services-modal .modal-top .logo img {
                max-height: 35px;
                max-width: 220px;
            }
            #lee-services-modal .modal-top .return-home { 
                margin-right: 15px; 
            }
            #lee-services-modal .modal-top .return-home a {
                
                    color: rgba(255,255,255,.7);
                    border-bottom: 1px solid rgba(255,255,255,.2);
                
                text-decoration: none;
                font-size: .9em;
                padding-bottom: 1px;
            }
            #lee-services-modal .modal-top .return-home a:hover {
                opacity: .8;
            }
            #lee-services-modal .modal-top .title {
                font-size: 22px;
                line-height: 24px;
                margin-bottom: 10px;
                font-weight: bold;
                text-align: center;
            }
            
                #lee-services-modal .modal-top .sub-login .btn { opacity: 1; border:0 }
                #lee-services-modal .modal-top .sub-login .btn:hover { opacity: .8; }
            
        @media (min-width: 992px) {
            #lee-services-modal.packages_1 {
                width: 650px;
            }
            #lee-services-modal.packages_2,
            #lee-services-modal.packages_3 {
                width: 80%;
            }
            #lee-services-modal.packages_4,
            #lee-services-modal.packages_5 {
                width: 90%;
            }
        }
        @media (min-width: 1200px) {
            #lee-services-modal.packages_2 {
                width: 650px;
            }
            #lee-services-modal.packages_3 {
                width: 900px;
            }
            #lee-services-modal.packages_4 {
                width: 1050px;
            }
            #lee-services-modal.packages_5  {
                width: 1200px;
            }
        }
        @media (max-width: 991px) {
            #lee-services-modal .wall-header { 
                text-align: center;
            }
            #lee-services-modal .modal-top .pull-right {
                float: none!important;
                display: block;
                margin-top: 15px;
            }
        }
    </style>
    <div id="lee-subscription-wall" data-instance="subscription" data-days="30" class="p402_hide hidden-print">
        <div id="lee-subscription-wall-modal" class="modal fade" tabindex="-1" role="dialog">
            <div id="lee-services-modal" class="modal-dialog" role="document">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-top ">
                            <div class="wall-header">
                                <div class="logo"><a href="/">
                                        <img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></a>
                                </div><div class="pull-right">
                                        <div class="return-home"><a href="/">Back to homepage</a></div><div class="sub-login"><a class="btn btn-default" href="https://www.stltoday.com/users/login/?referer_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" >Subscriber Login</a></div>
                                    </div>
                                    <div class="clearfix"></div></div>
                            
                            
                                <div class="title">FREE Subscription — No Credit Card Required!</div>
                                <div class="text-center" style="margin-bottom: 10px;">
                                    This holiday season the St. Louis Post-Dispatch is partnering with
                                    
                                        <strong>McBride Homes</strong>
                                        who is sponsoring 
                                    
                                    <span class="holiday-line">
                                        <strong>5,000 free 3-month digital subscriptions for new subscribers.</strong>
                                    </span>
                                </div>
                            </div>
                            <section id="lee-services-list" class="lee-services-list">
        <div class="loading text-center">
            <i class="fas tnt-spinner tnt-spin tnt-spin tnt-3x tnt-fw"></i>
            <div class="sr-only">Loading&hellp;</div>
        </div>
        <div class="packages row"></div>
    </section><template id="lee-service-template" class="hide">
        <div class="col-md-{{col}} {{has_featured_class}}">
            <div class="package {{has_promotion_class}} {{special_title_class}} {{special_label_class}} {{level}} {{disabled}} {{banner_class}}">
                <div class="header">
                    <div class="title">{{title}}</div>
                    <div class="description">{{description}}</div>
                    <div class="banner">{{banner}}</div>
                </div>
                <div class="footer">
                    <div class="price-wrapper">
                        <span class="price">                                    
                            <span class="sign">{{format_dollars}}</span>
                            <span class="amount">{{start_price}}</span>
                            <span class="cents">{{format_cents}}</span>
                        </span>
                        <span class="promotion price">                                    
                            <span class="sign">{{promotional_format_dollars}}</span>
                            <span class="amount">{{promotional_price}}</span>
                            <span class="cents">{{promotional_format_cents}}</span>
                        </span>
                        <span class="term">{{term}}</span>
                    </div>
                    <div class="promotion term">(renews at {{format_dollars}}{{start_price}}{{format_cents}}/month + tax)</div> 
                    <a class="btn btn-block btn-primary purchase text-uppercase {{disabled}}" href="{{purchase_url}}#tracking-source=subscription-wall-modal&ir=true" >{{action_button}}</a>
                </div>
                <div class="clearfix"></div>
            </div>
        </div>
    </template>
    
    <template id="lee-service-template-single" class="hide">
        <div class="row single-package {{has_promotion_class}} {{level}} {{special_title_class}} {{special_label_class}} {{disabled}}">
            <div class="col-md-6 text-center offer-col">
                <div class="offer-inner">
                    <div class="rate text-uppercase">
                                <div><img style="max-width: 90%; max-height: 90px; " src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/site/resources/images/holiday_sponsor.png?_dc=1670943623" alt="McBride Homes"></div>
                            
                    </div><a class="btn btn-block btn-primary purchase text-uppercase" href="https://subscriber.stltoday.com/cgi-bin/accept?prmo=FREE-DEC22" >Get Now</a>
                        <div class="special-title">Terms and Conditions apply.</div>
                </div>
            </div>
            <div class="col-md-6 html-col"> 
                <div class="html">{{html}}</div>
                <div class="clearfix"></div>
            </div>
            
            <div class="clearfix"></div>
        </div>
    </template><script>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</script></div>
                </div>
            </div>
        </div>
    </div><script>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</script>
        <div class="tnt-ads-container text-center hidden-print "><div style="min-height:1px; min-width:2px; margin:0!important;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/stltoday.com/sports/high-school/all-metro/girls-cross-country" data-dfp-custom-pos="fixed-impact-top, atf" id="fixed-impact-top" data-dfp-size="[2,1]"></div></div>
    
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.stltoday.com/users/admin/contribute/article/?assetid=f6aec1ca-8248-11ed-b39f-0362ef716cce&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.stltoday.com/users/admin/contribute/article/?from_section=/sports/high-school/all-metro/girls-cross-country"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.stltoday.com/tncms/admin/editorial-asset/?edit=f6aec1ca-8248-11ed-b39f-0362ef716cce"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        <style>
            #lee-holiday-banner {
                background-color: #fff;
                color: #fff;
                font-weight: normal;
                text-align: center;
                font-size: 17px;
                position: relative;
                overflow: hidden;
                text-shadow: 1px 0px 0px rgb(255 255 255);
                user-select: none;
                border-top: 5px solid #b90624;
            }
            #lee-holiday-banner a { color: #ba0424; text-decoration: none; }
            #lee-holiday-banner .wrap {
                padding: 0 15px;
                margin: 0 auto;
                max-width: 1620px;
                z-index: 1;
                position: relative;
            }
            #lee-holiday-banner .copy {
                margin: 0 auto;
                max-width: 1000px;
                padding: 15px 0;
            }
            #lee-holiday-banner .logo {
                float: right;
                margin-left: 15px; 
                background-color: #fff;
                margin-top: 24px;
                position: absolute;
                right: 15px;
            }
            #lee-holiday-banner strong { font-weight: 800; }
            #lee-holiday-banner .logo img { max-width: 200px; max-height: 100px; }
            #lee-holiday-banner .holiday-bg { 
                z-index:0;
                position: absolute;
                width: 100%;
                top:0;
                bottom:0;
                right:0;
                left:0;
            }
            #lee-holiday-banner .holiday-left {
                left: 20%;
                bottom: 0;
                position: absolute;
            }
            #lee-holiday-banner .holiday-left img,
            #lee-holiday-banner .holiday-right img { max-width: 300px; }
            #lee-holiday-banner .holiday-right {
                right: 20%;
                bottom: 0;
                position: absolute;
            }
            #lee-holiday-banner .holiday-btn { margin: 12px 0 8px; }
            #lee-holiday-banner .holiday-btn span {
                background-color: #ba0424;
                color: #fff;
                text-shadow: none;
                display: inline-block;
                padding: 5px 20px;
                border-radius: 20px;
                font-weight: 500;
            }
            #lee-holiday-banner .holiday-line, #lee-holiday-banner small { display: block; }
            #lee-holiday-banner small { font-size: 11px; }
            
            @media (max-width: 1500px) {
                #lee-holiday-banner .holiday-left img,
                #lee-holiday-banner .holiday-right img { max-width: 250px; }
            }
            @media (max-width: 1200px) {
                #lee-holiday-banner .holiday-left { left: 2%; }
                #lee-holiday-banner .holiday-right { right: 2%; }
                #lee-holiday-banner .holiday-left,
                #lee-holiday-banner .holiday-right { opacity: .3; }
                #lee-holiday-banner { text-align: left; }
                #lee-holiday-banner .logo {
                    margin-left: 10px;
                    margin-top: 10px;
                    position: relative;
                    right:0;
                }
            }
            @media (max-width: 991px) {
                #lee-holiday-banner .logo img { max-width: 120px; }
                #lee-holiday-banner { font-size: 13px; }
            }
            @media (max-width: 767px) {
                #lee-holiday-banner .holiday-left { left: -5%; }
                #lee-holiday-banner .holiday-right { right: -5%; }
                #lee-holiday-banner .holiday-left img,
                #lee-holiday-banner .holiday-right { max-width: 220px; }
                #lee-holiday-banner .holiday-line { display: inline; }
            }
        </style>
        <div id="lee-holiday-banner">
            <a href="https://subscriber.stltoday.com/cgi-bin/accept?prmo=FREE-DEC22">
                <div class="holiday-bg">
                    <div class="holiday-left"><img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/images/xmas_left.png?_dc=1671747505"></div>
                    <div class="holiday-right"><img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/images/xmas_right.png?_dc=1671747505"></div>
                    <!--<div class="holiday-center"><img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/images/fall_3.png"></div>-->
                </div>
                <div class="wrap"><div class="logo"><img src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/site/resources/images/holiday_sponsor.png?_dc=1670943623" alt="McBride Homes"></div><div class="copy">
                        <div>This holiday season the St. Louis Post-Dispatch is partnering with
                                
                                    <strong>
                                        McBride Homes
                                    </strong>
                                    who is sponsoring 
                                
                                <span class="holiday-line"> <strong>5,000 free 3-month digital subscriptions for new subscribers.</strong></span></div>
                        <div class="holiday-btn"><span>Get Now</span></div>
                        <div><small>Terms and Conditions apply.</small></div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </a>
        </div><div id="tncms-region-global-above-header" class="tncms-region full-region"><div id="tncms-block-1246641" class="tncms-block"></div></div><form method="post" action="https://www.stltoday.com/users/logout/" id="user-logout-form"><input type="hidden" name="referer_url" value="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"><input type="submit" name="logout" value="Logout" class="hide">
    </form>
    
    <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left" tabindex="-1" aria-expanded="false" aria-label="Left Main Menu">
        <div class="offcanvas-menu-inner">
            <button aria-label="Close Main Menu" role="button" class="offcanvas-close-btn in-drawer">
                <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 12 12" stroke="currentColor" stroke-width="1" stroke-linecap="round" width="24" height="24">
        <line x1="11" y1="1" x2="1" y2="11"></line>
        <line x1="1" y1="1" x2="11" y2="11"></line>
    </svg>
            </button>
            <div class="in-drawer-logo">
                <a href="/sports/high-school/"><img class="img-responsive" alt="STLtoday.com" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></a>
            </div><div class="mobile-weather">
                <a href="/weather/?weather_zip=63101">
                    <span class="icon pull-left">
                        <span class="fas tnt-wi-night-alt-snow"></span>
                    </span>
                    <span class="pull-left">
                        <span class="temp">4&deg;</span>
                    </span>
                    <span class="clearfix"></span>
                </a>
            </div><div class="hamburger-user-controls visible-sm visible-xs">
                <div class="user-controls show-onload clearfix"><div class="not-logged-in">
                            <ul class="list-inline">
                                <li>
                                    <a href="https://www.stltoday.com/users/login/?referer_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                                        <span class="user-avatar pull-left"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" stroke="currentColor" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round" fill="none">
        <circle cx="12" cy="8" r="5" />
        <path d="M3,21 h18 C 21,12 3,12 3,21"/>
    </svg></span> Log In
                                    </a>
                                </li><li><a href="/members/join/" class="btn btn-primary btn-sm login-btn user-control-link lee-featured-subscription-head" rel="nofollow">Subscribe</a></li></ul>
                        </div>
                        <div class="logged-in">
                            <ul class="list-inline">
                                <li>
                                    <a href="https://www.stltoday.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                                        <span class="pull-left user-avatar"><img class="lee-user-avatar" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/images/user_no_avatar.82c8fc38eb25dca10493a994ca1bfb90.png" height="24" width="24" alt="user icon"></span>
                                        <span class="tn-user-screenname">Guest</span>
                                    </a>
                                </li>
                                <li><a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form').submit(); return false;" rel="nofollow">Logout</a></li>
                            </ul>
                            <div class="service-controls has-service"><div><a class="btn btn-primary btn-sm eedition-btn" href="/eedition/">Read Today's E-edition</a></div></div>
                        </div></div>
            </div>
    
            <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
            <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><ul id="mobile-nav-left_menu" class="nav navbar-nav nav-level-top" aria-label="navigation"><li>
                <a class="nav-link nav-hometnt-section-stltoday" href="/" >
                    
                        <span class=""></span>
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">STLtoday</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-news" href="/news/" >
                                    <span class="nav-label">News</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-sports" href="/sports/" >
                                    <span class="nav-label">Sports</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-entertainment" href="/entertainment/" >
                                    <span class="nav-label">Entertainment</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-boys-sports" href="/sports/high-school/sports-index/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Boys Sports</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-baseball" href="/sports/high-school/baseball/" >
                                    <span class="nav-label">Baseball</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-basketball" href="/sports/high-school/boys-basketball/" >
                                    <span class="nav-label">Basketball</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-cross-country" href="/sports/high-school/boys-cross-country/" >
                                    <span class="nav-label">Cross Country</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-football" href="/sports/high-school/football/" >
                                    <span class="nav-label">Football</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-golf-fall" href="/sports/high-school/boys-golf-fall/" >
                                    <span class="nav-label">Golf - Fall</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-golf-spring" href="/sports/high-school/boys-golf-spring/" >
                                    <span class="nav-label">Golf - Spring</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-hockey" href="/sports/high-school/hockey/" >
                                    <span class="nav-label">Hockey</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-lacrosse" href="/sports/high-school/boys-lacrosse/" >
                                    <span class="nav-label">Lacrosse</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-soccer" href="/sports/high-school/boys-soccer/" >
                                    <span class="nav-label">Soccer</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-swimming" href="/sports/high-school/boys-swimming/" >
                                    <span class="nav-label">Swimming</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-tennis" href="/sports/high-school/boys-tennis/" >
                                    <span class="nav-label">Tennis</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-track" href="/sports/high-school/boys-track/" >
                                    <span class="nav-label">Track</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-volleyball" href="/sports/high-school/boys-volleyball/" >
                                    <span class="nav-label">Volleyball</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-water-polo" href="/sports/high-school/water-polo/" >
                                    <span class="nav-label">Water Polo</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-wrestling" href="/sports/high-school/wrestling/" >
                                    <span class="nav-label">Wrestling</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-girls-sports" href="/sports/high-school/sports-index/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Girls Sports</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-basketball" href="/sports/high-school/girls-basketball/" >
                                    <span class="nav-label">Basketball</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-cross-country" href="/sports/high-school/girls-cross-country/" >
                                    <span class="nav-label">Cross Country</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-field-hockey" href="/sports/high-school/field-hockey/" >
                                    <span class="nav-label">Field Hockey</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-golf-fall" href="/sports/high-school/girls-golf-fall/" >
                                    <span class="nav-label">Golf - Fall</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-lacrosse" href="/sports/high-school/girls-lacrosse/" >
                                    <span class="nav-label">Lacrosse</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-soccer" href="/sports/high-school/girls-soccer/" >
                                    <span class="nav-label">Soccer</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-softball-fall" href="/sports/high-school/softball-fall/" >
                                    <span class="nav-label">Softball - Fall</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-softball-spring" href="/sports/high-school/softball-spring/" >
                                    <span class="nav-label">Softball - Spring</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-swimming" href="/sports/high-school/girls-swimming/" >
                                    <span class="nav-label">Swimming</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-tennis" href="/sports/high-school/girls-tennis/" >
                                    <span class="nav-label">Tennis</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-track" href="/sports/high-school/girls-track/" >
                                    <span class="nav-label">Track</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-volleyball" href="/sports/high-school/girls-volleyball/" >
                                    <span class="nav-label">Volleyball</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-wrestling" href="/sports/high-school/girls-wrestling/" >
                                    <span class="nav-label">Wrestling</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-schedules-and-scores" href="/sports/high-school/schedules/" >
                    <span class="nav-label">Schedules and scores</span>
                </a></li><li>
                <a class="nav-linktnt-section-schools" href="/schools/" >
                    <span class="nav-label">Schools</span>
                </a></li><li>
                <a class="nav-linktnt-section-stats" href="http://www.stltoday.com/sports/high-school/stats/"  data-new-window="true">
                    <span class="nav-label">Stats</span>
                </a></li><li>
                <a class="nav-linktnt-section-all-conference" href="https://www.stltoday.com/sports/high-school/all-conference-and-all-state-teams/collection_f0581a60-d24d-11e8-97cc-ff363e53200f.html"  data-new-window="true">
                    <span class="nav-label">All-Conference</span>
                </a></li><li>
                <a class="nav-linktnt-section-all-metro" href="/sports/high-school/all-metro/" >
                    <span class="nav-label">All-Metro</span>
                </a></li><li>
                <a class="nav-linktnt-section-athletes-of-the-week" href="/sports/high-school/athletes-of-the-week/" >
                    <span class="nav-label">Athletes of the Week</span>
                </a></li><li>
                <a class="nav-linktnt-section-prep-sports-talk-forum" href="http://interact.stltoday.com/forums/viewforum.php?f=14"  data-new-window="true">
                    <span class="nav-label">Prep Sports Talk Forum</span>
                </a></li><li>
                <a class="nav-linktnt-section-rankings" href="/sports/high-school/rankings/" >
                    <span class="nav-label">Rankings</span>
                </a></li><li>
                <a class="nav-linktnt-section-recruiting" href="/sports/high-school/recruiting/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Recruiting</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-area-college-signings-ncaa-division-i-and-ii" href="https://www.stltoday.com/sports/high-school/recruiting/class-of-2022-area-college-signings-ncaa-division-i-and-ii/table_da815b68-418d-11ec-91ea-e372a19f4691.html"  data-new-window="true">
                                    <span class="nav-label">Area college signings: NCAA Division I and II</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-area-college-signings-ncaa-division-iii-naia-juco" href="https://www.stltoday.com/sports/high-school/recruiting/class-of-2022-area-college-signings-ncaa-division-iii-naia-juco/table_298cffca-4196-11ec-8e50-3fcbc0df733d.html"  data-new-window="true">
                                    <span class="nav-label">Area college signings: NCAA Division III, NAIA, JUCO</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-post-dispatch-super-30" href="/sports/high-school/football/super-30/" >
                                    <span class="nav-label">Post-Dispatch Super 30</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-seeking-area-college-signings" href="http://www.stltoday.com/sports/high-school/seeking-area-college-signings/article_602df1b0-691c-11e4-8804-57afe68fe2fd.html"  data-new-window="true">
                                    <span class="nav-label">Seeking area college signings</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-scholar-athletes" href="/sports/high-school/scholar-athletes/" >
                    <span class="nav-label">Scholar Athletes</span>
                </a></li></ul></div>
            <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"><ul id="mobile-nav-left-below_menu" class="nav navbar-nav nav-level-top" aria-label="navigation"><li>
                <a class="nav-linktnt-section-buy-sell" href="/ads/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Buy & Sell</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-place-an-ad" href="/ads/place-an-ad/" >
                                    <span class="nav-label">Place an Ad</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-marketplace" href="/ads" >
                                    <span class="nav-label">Marketplace</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-public-notices" href="/ads/community/announcements/legal/?l=25" >
                                    <span class="nav-label">Public Notices</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-homes" href="/homes/" >
                                    <span class="nav-label">Homes</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-shop-local" href="/places/" >
                                    <span class="nav-label">Shop Local</span>
                                </a>
                            </li></ul></li><li>
                <a class="nav-linktnt-section-jobs" href="/jobs/" >
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-linktnt-section-customer-service" href="/help/subscriber-services/" >
                    
                        <span class=""></span>
                    <span class="nav-label">Customer service</span>
                </a><ul class="nav navbar-nav nav-level-sub"><li>
                                <a class="nav-linktnt-section-manage-subscription" href="/services/" >
                                    <span class="nav-label">Manage Subscription</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-activate-digital-subscription" href="/activate/" >
                                    <span class="nav-label">Activate Digital Subscription</span>
                                </a>
                            </li><li>
                                <a class="nav-linktnt-section-contact-us" href="/help/contact-us/" >
                                    <span class="nav-label">Contact us</span>
                                </a>
                            </li></ul></li></ul></div>
            <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1245402" class="tncms-block lee-follow-us branding-links"><div class="follow-links-1245402 follow-links default">
    
    <section id="block-1245402" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="/facebook" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="/twitter" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.linkedin.com/company/st.-louis-post-dispatch/" title="LinkedIn" target="_blank" rel="noopener" class="btn btn-xs btn-link li">
                    <i class="fab tnt-linkedin-in"></i>
                    <span class="sr-only">LinkedIn</span>
                </a>
            </li>
        
        
            <li>
                <a href="/youtube" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.pinterest.com/stltoday/" title="Pinterest" target="_blank" rel="noopener" class="btn btn-xs btn-link pt">
                    <i class="fab tnt-pinterest"></i>
                    <span class="sr-only">Pinterest</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.instagram.com/stltoday/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.stltoday.com",
  "sameAs" : ["/facebook","/twitter","https://www.linkedin.com/company/st.-louis-post-dispatch/","/youtube","https://www.pinterest.com/stltoday/","https://www.instagram.com/stltoday/"]
}
</script>
<div class="clearfix"></div></div></div>
            
            <div class="mobile-nav-copyright">
                <div class="lee-copy">&copy; 2022 Lee Enterprises</div>
                <div><a href="/terms">Terms of Service</a> <span class="text-muted">|</span> <a href="/privacy">Privacy Policy</a></div>
            </div>
        </div>
    </aside>

    <div id="mobile-search" class="modal" tabindex="-1" role="dialog">
        <div class="modal-dialog" role="document">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                        <span aria-hidden="true"><svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 12 12" stroke="currentColor" stroke-width="1" stroke-linecap="round" width="24" height="24">
        <line x1="11" y1="1" x2="1" y2="11"></line>
        <line x1="1" y1="1" x2="11" y2="11"></line>
    </svg></span>
                    </button>
                </div>
            <div class="modal-body">
                <form action="/search/" method="GET">
                    <input type="hidden" name="sd" value="desc">
                    <input type="hidden" name="l" value="25">
                    <input type="hidden" name="s" value="start_time">
                    <input type="hidden" name="f" value="html">
                    <input type="hidden" name="t" value="article,video,youtube,collection">
                    <input type="hidden" name="app" value="editorial">
                    <input type="hidden" name="nsa" value="eedition">
                        <input type="hidden" name="c" value="sports/high-school*">
                    <div class="input-group input-group-lg">
                        <input id="mobile-search-q" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control search-term" autocomplete="off">
                            <span class="input-group-btn">
                                <button class="btn btn-link" aria-label="Submit Site Search" type="submit">
                                    <svg xmlns="http://www.w3.org/2000/svg" iewBox="0 0 19.9 19.7" stroke-width="1.5" width="24" height="24">
        <g fill="none" stroke="currentColor">
            <path stroke-linecap="round" d="M18.5 18.3l-5.4-5.4"/>
            <circle cx="8" cy="8" r="7"/>
        </g>
    </svg>
                                </button>
                            </span>
                        </div>
                    </form>
                </div>
            </div>
        </div>
    </div><div id="offcanvas-container" class="offcanvas-inner">
        <div class="offcanvas-close-btn"></div><div id="site-navbar-container" class="hidden-print sticky">
        <div class="masthead hidden-sm hidden-xs container-fluid">
                <div class="row">
                    <div class="head-left col-md-8">
                        <div class="logo-search-grid">
                            <div class="logo">
                                    <style>
.logo-flp {
    position: relative;
    z-index:1;
}
.masthead .logo-flp, 
.masthead .logo-flp .front, 
.masthead .logo-flp .back {
    width: 300px;
    height: 40px;
}
.navbar-brand .logo-flp, 
.navbar-brand .logo-flp .front, 
.navbar-brand .logo-flp .back {
    width: 200px;
    height: 30px;
}
.logo-flp .wrap {
    transition: 1.5s;
    position: relative;
}
.logo-flp .front, 
.logo-flp .back {
    -webkit-backface-visibility: hidden;
    backface-visibility: hidden;
    transition: 1.5s;
    transform-style: preserve-3d;
    position: absolute;
    top: 0;
    left: 0;
}
.logo-flp .front {
    z-index: 2;
    animation: flip-front 8s infinite;
}
.logo-flp .back,
.navbar-brand .logo-flp .front {
    display: flex;
    align-items: center;
}
.logo-flp .back {
    transform: rotateX(180deg);
    animation: flip-back 8s infinite;
}

@keyframes flip-front {
    0%,40%,100% {
        transform: rotateX(0deg);
    }    
    60%,80% {
        transform: rotateX(180deg);
    }
}

@keyframes flip-back {
    0%,40%,100% {
        transform: rotateX(180deg);
    }
    60%,80% {
        transform: rotateX(0deg);
    }
}
</style><div class="logo-flp">
    <div class="wrap">
        <a href="/sports/high-school/">
            <div class="front"><img  alt="STLtoday.com" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></div>
            <div class="back"><img  alt="Where your story lives" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/images/logo-tagline.png?_dc=1671747505"></div>
        </a>
    </div>
</div>
                            </div>
                            <div class="search">
                                <form action="/search/" method="GET">
                                    <input type="hidden" name="sd" value="desc">
                                    <input type="hidden" name="l" value="25">
                                    <input type="hidden" name="s" value="start_time">
                                    <input type="hidden" name="f" value="html">
                                    <input type="hidden" name="t" value="article,video,youtube,collection">
                                    <input type="hidden" name="app" value="editorial">
                                    <input type="hidden" name="nsa" value="eedition">
                                        <input type="hidden" name="c" value="sports/high-school*">
                                    <div class="input-group">
                                        <span class="input-group-btn">
                                            <button class="btn btn-link" aria-label="Submit Site Search" type="submit">
                                                <svg xmlns="http://www.w3.org/2000/svg" iewBox="0 0 19.9 19.7" stroke-width="1.5" width="24" height="24">
        <g fill="none" stroke="currentColor">
            <path stroke-linecap="round" d="M18.5 18.3l-5.4-5.4"/>
            <circle cx="8" cy="8" r="7"/>
        </g>
    </svg>
                                            </button>
                                        </span>
                                        <input name="q" title="Site Search" type="text" placeholder="Search ..." class="form-control search-term" autocomplete="off">
                                    </div>
                                </form>
                            </div>
                        </div>
                    </div>
                    <div class="head-right col-md-4">
                        <div class="no-service"><a href="/members/join/" class="btn btn-primary btn-lg lee-featured-subscription-head">Subscribe</a><script>
            jQuery(document).ready(function($){
                if(!__tnt.user.services && window.leeMembershipPackages && !window.oFeaturedPackage){
                    try {
                        var oFeaturedPackage = false;
                        $.each(window.leeMembershipPackages, function(i, oService){
                            if(parseInt(oService.WebFeatureFG) != 2 && oService.WebStartPrice != ''){
                                if(oService.WebStartPrice.match('"featured":"true"')){
                                    window.oFeaturedPackage = oService;
                                    return false;
                                }
                            }
                        });

                        if(window.oFeaturedPackage) {
                            function lee_formatPackagePriceBtn(sPrice){
                                var p = sPrice.split('.');
                                if( p[1] && p[1] === '00' ) return { cost: p[0], format_dollars: '$'};
                                if( p[0] && p[0] === '0' ) return { cost: p[1], format_cents: '&cent;'};
                                return { cost: sPrice, format_dollars: '$'};
                            }
                                
                            var oPackageCustom = JSON.parse(window.oFeaturedPackage.WebStartPrice);
                            
                            if(oPackageCustom.promotional_price && oPackageCustom.promotional_price != ''){ 
                                var sPrice = lee_formatPackagePriceBtn(oPackageCustom.promotional_price);
                            } else {
                                var sPrice = lee_formatPackagePriceBtn(oPackageCustom.start_price);
                            }
                            
                            if( !oPackageCustom.term ) oPackageCustom.term = 'per month';
                            
                            var sButtonHref = '{{purchase_url}}'.replace('{{level}}',window.oFeaturedPackage.HomeMembership);
                            
                            
                            var sButtonText = '<span>Subscribe</span> <span class="term">'+(sPrice.format_dollars ? sPrice.format_dollars : '')+sPrice.cost+(sPrice.format_cents ? sPrice.format_cents : '' + ' '+ oPackageCustom.term +'</span>');
                            sButtonHref = sButtonHref.replace('{{purchase_url}}', oPackageCustom.purchase_url);
                            if( $('.lee-featured-subscription-head').length > 0){
                                $('.lee-featured-subscription-head').each(function(){
                                    $(this).addClass('has-falcon-package');
                                    $(this).html(sButtonText).attr('href', sButtonHref+'#tracking-source=header&ir=true');
                                });
                            }
                            if($('#join-btn-mobile-link').length > 0){
                                $('#join-btn-mobile-link').attr('href', sButtonHref+'#tracking-source=header&ir=true');
                            }
                        }
                    } catch (e) {
                        if(window.console) console.warn(e);
                    }
                }
            });
        </script></div><div class="has-service">
                                <a class="btn btn-primary btn-lg" href="/eedition/">Read Today's E-Edition</a>
                            </div></div>
                </div>
            </div><nav id="main-navigation" class="navbar" role="navigation">
                <div class="navbar-header"><button id="lee-main-menu-btn" aria-label="Main Menu" aria-expanded="false" type="button" class="hamburger-desktop navbar-toggle pull-left" data-toggle="offcanvas_lee" data-target="left">
                            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 20 20" width="24" height="24">
        <rect x="1" y="4" rx="0.5" fill="currentColor" width="14" height="1.5"></rect>
        <rect x="1" y="9" rx="0.5" fill="currentColor" width="10" height="1.5"></rect>
        <rect x="1" y="14" rx="0.5" fill="currentColor" width="14" height="1.5"></rect>
    </svg>
                        </button><div class="navbar-brand pos_left">
                        <div class="site-logo-container">
                                <div class="logo-flp">
    <div class="wrap">
        <a href="/sports/high-school/">
            <div class="front"><img class="img-responsive" alt="STLtoday.com" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></div>
            <div class="back"><img class="img-responsive" alt="Where your story lives" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/images/logo-tagline.png?_dc=1671747505"></div>
        </a>
    </div>
</div>
                        </div>
                    </div><div class="pull-right visible-sm visible-xs subscribe-btn">
                            <div class="join-btn-mobile pull-left">
                                
                                    <a id="join-btn-mobile-link" href="/members/join/" class="no-service btn btn-primary">Join</a>
                                
                            </div>
                            <div class="search-mobile pull-left">
                                <a class="btn btn-link" aria-label="Site Search" data-toggle="modal" data-target="#mobile-search">
                                    <svg xmlns="http://www.w3.org/2000/svg" iewBox="0 0 19.9 19.7" stroke-width="1.5" width="24" height="24">
        <g fill="none" stroke="currentColor">
            <path stroke-linecap="round" d="M18.5 18.3l-5.4-5.4"/>
            <circle cx="8" cy="8" r="7"/>
        </g>
    </svg>
                                </a>
                            </div>
                        </div></div>
                
                <div id="navbar-collapse" class="navbar-collapse collapse"><div class="lee-nav-right-region pull-right">
                            <div class="user-controls show-onload clearfix pull-left"><div class="notification-button pull-left" data-control="notification">
                                        <span class="badge-dot tnt-bg-accent"></span>
                                        <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" fill="currentColor" viewBox="0 0 16 16">
        <path d="M8 16a2 2 0 0 0 2-2H6a2 2 0 0 0 2 2zM8 1.918l-.797.161A4.002 4.002 0 0 0 4 6c0 .628-.134 2.197-.459 3.742-.16.767-.376 1.566-.663 2.258h10.244c-.287-.692-.502-1.49-.663-2.258C12.134 8.197 12 6.628 12 6a4.002 4.002 0 0 0-3.203-3.92L8 1.917zM14.22 12c.223.447.481.801.78 1H1c.299-.199.557-.553.78-1C2.68 10.2 3 6.88 3 6c0-2.42 1.72-4.44 4.005-4.901a1 1 0 1 1 1.99 0A5.002 5.002 0 0 1 13 6c0 .88.32 4.2 1.22 6z"/>
    </svg>
                                    </div><div class="not-logged-in pull-left">
                                        <ul class="list-inline">
                                            <li>
                                                <a href="https://www.stltoday.com/users/login/?referer_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                                                    <span class="user-avatar">
                                                        <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" stroke="currentColor" stroke-width="1.5" stroke-linecap="round" stroke-linejoin="round" fill="none">
        <circle cx="12" cy="8" r="5" />
        <path d="M3,21 h18 C 21,12 3,12 3,21"/>
    </svg>
                                                    </span>
                                                    Log In
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="logged-in pull-left">
                                        <ul class="hide-offcanvas list-inline">
                                            <li class="dropdown pull-right">
                                                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown">
                                                    <div class="user-avatar pull-right"><img class="lee-user-avatar" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/images/user_no_avatar.82c8fc38eb25dca10493a994ca1bfb90.png" height="24" width="24" alt="user icon"></div>
                                                    <div class="user-welcome pull-left">Welcome, <span class="tn-user-screenname">Guest</span></div>
                                                </div>
                                                <ul class="lee-membership-container dropdown-menu dropdown-menu-right" role="menu"><li class="lee-membership-item">
                                                                <div class="user-level"><span class="level lee-membership-package"></span> Member</div>
                                                                <div class="user-link"><a href="//stltoday.com/services/">My Subscription</a></div>
                                                                <!--<div class="user-link"><a href="/members/">See Benefits</a></div>
                                                                <div class="user-link"><a href="/members/exclusives/">Members Only</a></div>-->
                                                                <div class="user-link"><a href="/helpcenter/">Help Center</a></div>
                                                            </li><li role="presentation" class="dropdown-header">My Account</li>
                                                        <li role="menuitem"><a href="https://www.stltoday.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                                                        <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.stltoday.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                                                        <li role="menuitem"><a href="https://www.stltoday.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                                                        <li role="separator" class="divider"></li>
                                                        <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li></ul>
                                            </li>
                                        </ul>
                                    </div><div class="clearfix"></div>
                            </div>
                        </div><div class="navbar-left">
                        <div class="nav-menu pull-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-sports"  href="/sports/high-school/sports-index/" ><span class="nav-label">Sports</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-schools"  href="/schools/" ><span class="nav-label">Schools</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-scoreboard"  href="/sports/high-school/schedules/" ><span class="nav-label">Scoreboard</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-stats"  href="/sports/high-school/stats/" ><span class="nav-label">Stats</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-all-metro"  href="/sports/high-school/all-metro/" ><span class="nav-label">All-Metro</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-scholar-athletes"  href="/sports/high-school/scholar-athletes/" ><span class="nav-label">Scholar Athletes</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-stltoday"  href="http://www.stltoday.com/"  data-new-window="true"><span class="nav-label">STLtoday</span>
                    
                </a></li></ul></div><div class="nav-weather">
                                    <ul class="nav navbar-nav">
                                        <li class="current-conditions">
                                            <a href="/weather/?weather_zip=63101">
                                                <span class="icon pull-left">
                                                    
                                                        <span class="badge-dot tnt-bg-accent"></span>
                                                    
                                                    <span class="fas tnt-wi-night-alt-snow"></span>
                                                </span>
                                                <span class="pull-left">
                                                    <span class="temp">4&deg;</span>
                                                    <span class="cond">Light Snow/Wind</span>
                                                </span>
                                                <span class="clearfix"></span>
                                            </a>
                                        </li>
                                    </ul>
                                </div></div>
                    </div>
                </div>  
            </nav><div id="lee-mobile-share">
                    <div class="share-text pull-left">Share This <i class="fas tnt-arrow-right"></i></div>
                    <div class="share-menu pull-right"><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&via=STLhssports&url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.stltoday.com/tncms/asset/editorial/f6aec1ca-8248-11ed-b39f-0362ef716cce" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSt.%20Louis%20Post-Dispatch%5D%20Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&body=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
                    <div class="clearfix"></div>
                </div><div id="fixed-article-header">
                        <div class="col-left pull-left">
                            <div class="title">Mary McKenzie, freshman, Cor Jesu</div>
                        </div>
                        <div class="col-right"><div class="sub-button pull-right"><a href="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html?mode=comments" class="btn btn-primary ">
            <span class="fas tnt-comments"></span> 
            <span id="openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-top" twt-comment-count="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" twt-article-id="f6aec1ca-8248-11ed-b39f-0362ef716cce">0</span> Comments
        </a>
        <script type="text/javascript">
            fetch("https://open-api.spot.im/v1/messages-count?spot_id=sp_omoe7asV&posts_ids=f6aec1ca-8248-11ed-b39f-0362ef716cce")
                .then(function(response) {
                    return response.json();
                })
                .then(function(openWeb) {
                    if (openWeb && openWeb.messages_count) {
                        document.getElementById("openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-top").innerHTML = openWeb.messages_count['f6aec1ca-8248-11ed-b39f-0362ef716cce'];
                    }
                });
        </script></div><div class="pull-right social">
                                <div class="share-label pull-left">Share this</div><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&via=STLhssports&url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.stltoday.com/tncms/asset/editorial/f6aec1ca-8248-11ed-b39f-0362ef716cce" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSt.%20Louis%20Post-Dispatch%5D%20Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&body=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html', '[data-copy-inline-f6aec1ca-8248-11ed-b39f-0362ef716cce]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-f6aec1ca-8248-11ed-b39f-0362ef716cce
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-f6aec1ca-8248-11ed-b39f-0362ef716cce-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f6aec1ca-8248-11ed-b39f-0362ef716cce" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f6aec1ca-8248-11ed-b39f-0362ef716cce" class="save-list-f6aec1ca-8248-11ed-b39f-0362ef716cce-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f6aec1ca-8248-11ed-b39f-0362ef716cce" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
<div class="clearfix"></div>
                            </div>
                            <div class="clearfix"></div>
                        </div>
                        <div class="clearfix"></div>
                    </div></div>
    
    <div id="main-body-container"><div id="tncms-region-global-below-header" class="tncms-region "><div id="tncms-block-1409144" class="tncms-block"></div></div>
    <section aria-label="Main Content" id="main-page-container" class="container" tabindex="-1"><div class="container-breakout ads-dfp-ppid top-leader-ad-col ad-col">
        <div class="visible-lg visible-md" data-slug="homepage"><div class="tnt-ads-container text-center hidden-print hidden-xs"><div style="min-height:250px; min-width:970px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/stltoday.com/sports/high-school/all-metro/girls-cross-country" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top" data-dfp-size="[[970,250],[970,90],[728,90]]" data-lazy="true" data-ppid="true"></div></div>
    </div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-print hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/stltoday.com/sports/high-school/all-metro/girls-cross-country" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top-tablet" data-dfp-size="[728,90]" data-lazy="true" data-ppid="true"></div></div>
    </div><div class="tnt-ads-container text-center hidden-print hidden-sm hidden-md hidden-lg"><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/stltoday.com/sports/high-school/all-metro/girls-cross-country" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top-mobile" data-dfp-size="[[320,50],[300,50]]" data-lazy="true" data-ppid="true"></div></div>
    
       </div>
            <div id="asset-container-top"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
        <div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1252525" class="tncms-block"><style>
@media screen and (max-width: 320px){#slsa-stats-nav .brand{margin:0 0 0 0.5em!important}#slsa-stats-nav form select{margin:0.2em 0.5em 0.5em 0.5em!important}#slsa-stats-nav .options{float:right!important;width:13em!important}}
@media screen and (min-width: 321px) and (max-width: 620px) {#slsa-stats-nav .brand {margin:0 0 0 0.5em!important}#slsa-stats-nav .options{float:right;width:13em}#slsa-stats-nav form{width:15em}#slsa-stats-nav form select + select{margin:0em 0.5em 0.5em 0.5em}}
@media screen and (min-width: 621px) {#slsa-stats-nav div.options{display:block;float:left}}
@media screen and (min-width: 1028px) {}
#slsa-stats-nav{background-color:#eee;color:#333!important;clear:both;border:1px #ddd solid;border-radius:0.3em;margin:0.2em}
#slsa-stats-nav .brand{display:block;float:left;margin:0.2em 0.5em 0.5em 0.5em;font-size:1.5em;line-height:1.5em;color:#333!important}
#slsa-stats-nav form select{display:block;float:left;width:12em;font-size:1em;height:1.5em;line-height:1.5em;margin:0.85em 0.5em 0.5em 0.5em;background-color:#fff;border:0}
#slsa-stats-nav .menu{float:right;font-size:1.5em;line-height:1.5em;margin:0.5em;color:#333!important}
</style>
<nav id="slsa-stats-nav"><!-- v0.3.2 -->
    <div class="brand" href="#">Stats Navigator</div>
    <div class="options">
        <form id="slsa-stats-nav-options">
            <select id="slsa_sports" onchange="location.href=this.options[selectedIndex].value" >
                <option>Pick a sport</option>
		<option value="http://stats.stlhighschoolsports.com/sports/baseball/stats/">Baseball</option>
		<option value="http://stats.stlhighschoolsports.com/sports/basketballboys/stats/">Basketball - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/basketballgirls/stats/">Basketball - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/crosscountryboys/stats/">Cross Country - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/crosscountrygirls/stats/">Cross Country - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/fieldhockey/stats/">Field Hockey</option>
		<option value="http://stats.stlhighschoolsports.com/sports/football/stats/">Football</option>
		<option value="http://stats.stlhighschoolsports.com/sports/golffallboys/stats/">Golf - Fall</option>
		<option value="http://stats.stlhighschoolsports.com/sports/golfgirls/stats/">Golf - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/golfspringboys/stats/">Golf - Spring</option>
		<option value="http://stats.stlhighschoolsports.com/sports/hockey/stats/">Hockey</option>
		<option value="http://stats.stlhighschoolsports.com/sports/lacrosseboys/stats/">Lacrosse - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/lacrossegirls/stats/">Lacrosse - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/soccerboys/stats/">Soccer - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/soccergirls/stats/">Soccer - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/softballfall/stats/">Softball - Fall</option>
		<option value="http://stats.stlhighschoolsports.com/sports/softballspring/stats/">Softball - Spring</option>
		<option value="http://stats.stlhighschoolsports.com/sports/swimmingboys/stats/">Swimming - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/swimminggirls/stats/">Swimming - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/tennisboys/stats/">Tennis - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/tennisgirls/stats/">Tennis - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/trackboys/stats/">Track - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/trackgirls/stats/">Track - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/volleyballboys/stats/">Volleyball - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/volleyballgirls/stats/">Volleyball - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/waterpolo/stats/">Water Polo - Boys</option>
		<option value="http://stats.stlhighschoolsports.com/sports/waterpologirls/stats/">Water Polo - Girls</option>
		<option value="http://stats.stlhighschoolsports.com/sports/wrestling/stats/">Wrestling</option>
		<option value="http://stats.stlhighschoolsports.com/sports/wrestlinggirls/stats/">Wrestling - Girls</option>                
            </select>
            <select id="slsa_schools" onchange="location.href=this.options[selectedIndex].value">
                <option>Pick a School</option>
		<option value="https://www.stltoday.com/schools/high-schools/affton/">Affton High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/althoff/">Althoff</option>
		<option value="https://www.stltoday.com/schools/high-schools/alton/">Alton High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/alton-marquette/">Marquette Catholic High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/barat-academy/">Barat Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/bayless/">Bayless High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/belleville-east/">Belleville East</option>
		<option value="https://www.stltoday.com/schools/high-schools/belleville-west/">Belleville West</option>
		<option value="https://www.stltoday.com/schools/high-schools/borgia/">Borgia</option>
		<option value="https://www.stltoday.com/schools/high-schools/breese-central/">Breese Central</option>
		<option value="https://www.stltoday.com/schools/high-schools/brentwood/">Brentwood High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/bunker-hill/">Bunker Hill High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/cahokia/">Cahokia High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/carbondale/">Carbondale High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/cardinal-ritter/">Cardinal Ritter College Prep</option>
		<option value="https://www.stltoday.com/schools/high-schools/carlinville/">Carlinville</option>
		<option value="https://www.stltoday.com/schools/high-schools/carlyle/">Carlyle High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/carnahan/">Carnahan High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/cbc/">CBC</option>
		<option value="https://www.stltoday.com/schools/high-schools/centralia-il/">Centralia IL</option>
		<option value="https://www.stltoday.com/schools/high-schools/chaminade/">Chaminade</option>
		<option value="https://www.stltoday.com/schools/high-schools/chester/">Chester High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/christian-academy-stl/">Christian Academy StL</option>
		<option value="https://www.stltoday.com/schools/high-schools/civic-memorial/">Civic Memorial High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/clayton/">Clayton High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/cleveland/">Cleveland High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/collegiate/">Collegiate School of Medicine &amp; Bioscience</option>
		<option value="https://www.stltoday.com/schools/high-schools/collinsville/">Collinsville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/columbia/">Columbia High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/confluence/">Confluence Preparatory Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/cor-jesu/">Cor Jesu</option>
		<option value="https://www.stltoday.com/schools/high-schools/crossroads-college-prep/">Crossroads College Prep</option>
		<option value="https://www.stltoday.com/schools/high-schools/crystal-city/">Crystal City High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/de-soto/">De Soto High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/desmet/">De Smet</option>
		<option value="https://www.stltoday.com/schools/high-schools/dubourg/">Bishop DuBourg</option>
		<option value="https://www.stltoday.com/schools/high-schools/duchesne/">Duchesne High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/dupo/">Dupo High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/east-st-louis/">East St. Louis High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/edwardsville/">Edwardsville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/eureka/">Eureka High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/festus/">Festus High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/fort-zumwalt-east/">Fort Zumwalt East</option>
		<option value="https://www.stltoday.com/schools/high-schools/fort-zumwalt-north/">Fort Zumwalt North</option>
		<option value="https://www.stltoday.com/schools/high-schools/fort-zumwalt-south/">Fort Zumwalt South</option>
		<option value="https://www.stltoday.com/schools/high-schools/fort-zumwalt-west/">Fort Zumwalt West</option>
		<option value="https://www.stltoday.com/schools/high-schools/fox/">Fox High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/francis-howell/">Francis Howell</option>
		<option value="https://www.stltoday.com/schools/high-schools/francis-howell-central/">Francis Howell Central</option>
		<option value="https://www.stltoday.com/schools/high-schools/francis-howell-north/">Francis Howell North</option>
		<option value="https://www.stltoday.com/schools/high-schools/freeburg/">Freeburg High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/gateway-academy/">Gateway Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/gateway-tech/">Gateway STEM</option>
		<option value="https://www.stltoday.com/schools/high-schools/gibault/">Gibault</option>
		<option value="https://www.stltoday.com/schools/high-schools/gillespie/">Gillespie High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/grandview/">Grandview High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/granite-city/">Granite City</option>
		<option value="https://www.stltoday.com/schools/high-schools/greenville-il/">Greenville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/hancock/">Hancock</option>
		<option value="https://www.stltoday.com/schools/high-schools/hardin-calhoun/">Hardin Calhoun</option>
		<option value="https://www.stltoday.com/schools/high-schools/hazelwood-central/">Hazelwood Central</option>
		<option value="https://www.stltoday.com/schools/high-schools/hazelwood-east/">Hazelwood East</option>
		<option value="https://www.stltoday.com/schools/high-schools/hazelwood-west/">Hazelwood West</option>
		<option value="https://www.stltoday.com/schools/high-schools/helias/">Helias</option>
		<option value="https://www.stltoday.com/schools/high-schools/herculaneum/">Herculaneum High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/hermann/">Hermann High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/hickman/">Hickman</option>
		<option value="https://www.stltoday.com/schools/high-schools/highland-il/">Highland High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/hillsboro-mo/">Hillsboro High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/holt/">Holt</option>
		<option value="https://www.stltoday.com/schools/high-schools/incarnate-word/">Incarnate Word</option>
		<option value="https://www.stltoday.com/schools/high-schools/jefferson/">Jeferson High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/jennings/">Jennings High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/jerseyville/">Jerseyville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/john-burroughs/">John Burroughs School</option>
		<option value="https://www.stltoday.com/schools/high-schools/kirkwood/">Kirkwood High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/ladue/">Ladue</option>
		<option value="https://www.stltoday.com/schools/high-schools/lafayette/">Lafayette High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/lebanon-il/">Lebanon High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/liberty/">Liberty</option>
		<option value="https://www.stltoday.com/schools/high-schools/liberty-christian-academy/">Liberty Christian Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/lift-for-life/">Lift for Life Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/lindbergh/">Lindbergh High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/litchfield/">Litchfield</option>
		<option value="https://www.stltoday.com/schools/high-schools/love-joy/">Lovejoy High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/lutheran-north/">Lutheran North</option>
		<option value="https://www.stltoday.com/schools/high-schools/lutheran-sc/">Lutheran St. Charles</option>
		<option value="https://www.stltoday.com/schools/high-schools/lutheran-south/">Lutheran South</option>
		<option value="https://www.stltoday.com/schools/high-schools/madison-il/">Madison High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/maplewood/">Maplewood-Richmond Heights</option>
		<option value="https://www.stltoday.com/schools/high-schools/marion/">Marion</option>
		<option value="https://www.stltoday.com/schools/high-schools/marissa/">Marissa High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/marquette/">Marquette High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/mascoutah/">Mascoutah High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/mater-dei/">Mater Dei</option>
		<option value="https://www.stltoday.com/schools/high-schools/mccluer/">McCluer High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/mccluer-north/">McCluer North High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/mccluer-south-berkeley/">McCluer South-Berkeley</option>
		<option value="https://www.stltoday.com/schools/high-schools/mcgivney/">Father McGivney High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/mckinley/">McKinley</option>
		<option value="https://www.stltoday.com/schools/high-schools/mehlville/">Mehlville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/metro-east-lutheran/">Metro-East Lutheran High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/metro-st-louis/">Metro</option>
		<option value="https://www.stltoday.com/schools/high-schools/micds/">MICDS</option>
		<option value="https://www.stltoday.com/schools/high-schools/miller-career-academy/">Miller Career Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/montgomery-county/">Montgomery County</option>
		<option value="https://www.stltoday.com/schools/high-schools/mount-vernon/">Mount Vernon</option>
		<option value="https://www.stltoday.com/schools/high-schools/mt-olive/">Mount Olive</option>
		<option value="https://www.stltoday.com/schools/high-schools/nashville/">Nashville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/nerinx-hall/">Nerinx Hall</option>
		<option value="https://www.stltoday.com/schools/high-schools/new-athens/">New Athens High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/new-haven/">New Haven High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/normandy/">Normandy High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/north-county-christian/">North County Christian</option>
		<option value="https://www.stltoday.com/schools/high-schools/north-point/">North Point</option>
		<option value="https://www.stltoday.com/schools/high-schools/north-tech/">North Tech High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/northwest-academy/">Northwest Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/northwest-cedar-hill/">Northwest Cedar Hill</option>
		<option value="https://www.stltoday.com/schools/high-schools/notre-dame/">Notre Dame</option>
		<option value="https://www.stltoday.com/schools/high-schools/oakville/">Oakville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/ofallon-christian/">O'Fallon Christian</option>
		<option value="https://www.stltoday.com/schools/high-schools/ofallon-il/">O'Fallon Township</option>
		<option value="https://www.stltoday.com/schools/high-schools/okawville/">Okawville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/okwaville/">Okwaville</option>
		<option value="https://www.stltoday.com/schools/high-schools/orchard-farm/">Orchard Farm High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/owensville/">Owensville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/pacific/">Pacific High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/parkway-central/">Parkway Central</option>
		<option value="https://www.stltoday.com/schools/high-schools/parkway-north/">Parkway North</option>
		<option value="https://www.stltoday.com/schools/high-schools/parkway-south/">Parkway South</option>
		<option value="https://www.stltoday.com/schools/high-schools/parkway-west/">Parkway West</option>
		<option value="https://www.stltoday.com/schools/high-schools/pattonville/">Pattonville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/perryville/">Perryville High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/piasa-southwestern/">Piasa</option>
		<option value="https://www.stltoday.com/schools/high-schools/principia/">Principia School</option>
		<option value="https://www.stltoday.com/schools/high-schools/priory/">Priory</option>
		<option value="https://www.stltoday.com/schools/high-schools/red-bud/">Red Bud High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/ritenour/">Ritenour High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/riverview-gardens/">Riverview Gardens</option>
		<option value="https://www.stltoday.com/schools/high-schools/roosevelt/">Roosevelt High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/rosati-kain/">Rosati-Kain</option>
		<option value="https://www.stltoday.com/schools/high-schools/roxana/">Roxana High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/seckman/">Seckman High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/sluh/">SLUH</option>
		<option value="https://www.stltoday.com/schools/high-schools/soldan/">Soldan High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-charles/">St. Charles High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-charles-west/">St. Charles West High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-clair/">St. Clair High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-dominic/">St. Dominic High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-james/">St. James High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-josephs-academy/">St. Joseph's Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-louis-christian/">St. Louis Christian Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-marys/">St. Mary's</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-pius-x/">St. Pius X</option>
		<option value="https://www.stltoday.com/schools/high-schools/st-vincent/">St. Vincent High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/staunton/">Staunton High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/steeleville-il/">Steeleville</option>
		<option value="https://www.stltoday.com/schools/high-schools/sullivan-mo/">Sullivan High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/summit/">Rockwood Summit</option>
		<option value="https://www.stltoday.com/schools/high-schools/sumner/">Sumner High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/thomas-jefferson/">Thomas Jefferson</option>
		<option value="https://www.stltoday.com/schools/high-schools/timberland/">Timberland High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/tower-grove-christian/">Tower Grove Christian</option>
		<option value="https://www.stltoday.com/schools/high-schools/triad/">Triad High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/trinity/">Trinity High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/troy-buchanan/">Troy Buchanan</option>
		<option value="https://www.stltoday.com/schools/high-schools/union/">Union High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/university-city/">University City High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/ursuline/">Ursuline Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/valle-catholic/">Valle Catholic</option>
		<option value="https://www.stltoday.com/schools/high-schools/valley-park/">Valley Park High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/valmeyer/">Valmeyer High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/vandalia/">Vandalia</option>
		<option value="https://www.stltoday.com/schools/high-schools/vashon/">Vashon High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/vianney/">Vianney</option>
		<option value="https://www.stltoday.com/schools/high-schools/villa-duchesne/">Villa Duchesne</option>
		<option value="https://www.stltoday.com/schools/high-schools/visitation/">Visitation Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/warrenton/">Warrenton High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/washington/">Washington High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/waterloo/">Waterloo High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/webster-groves/">Webster Groves High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/wesclin/">Wesclin High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/westminster/">Westminster Christian Academy</option>
		<option value="https://www.stltoday.com/schools/high-schools/whitfield/">Whitfield School</option>
		<option value="https://www.stltoday.com/schools/high-schools/windsor-jefferson-county/">Windsor High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/winfield/">Winfield High School</option>
		<option value="https://www.stltoday.com/schools/high-schools/wood-river/">East Alton-Wood River</option>
		<option value="https://www.stltoday.com/schools/high-schools/wright-city/">Wright City</option>
            </select>
        </form>
        <script>
            jQuery(document).ready(function($) {
                $('#slsa-stats-nav form').trigger('reset')
            })
        </script>
    </div>
    <div style="clear:both"></div>
</nav></div></div>
<article itemscope itemtype="https://schema.org/Article" id="asset-f6aec1ca-8248-11ed-b39f-0362ef716cce" class="asset article-default"  data-url="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/4ce82390-59b2-11e6-a3c5-b77ec6e8d16d.png?crop=375%2C375%2C30%2C0&resize=200%2C200&order=crop%2Cresize">
            <meta itemprop="width" content="200">
            <meta itemprop="height" content="200">
        </div>
        <meta itemprop="name" content="stltoday.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" />
    <meta itemprop="isAccessibleForFree" content="true"/>
    
    <div class="asset-masthead  container-breakout"><div class="container">
            <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
    <span>Mary McKenzie, freshman, Cor Jesu</span>
</h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-fa4aa9be-ce14-11e6-b397-db2e5928c384-asset-f6aec1ca-8248-11ed-b39f-0362ef716cce" class="tnt-byline asset-byline" itemprop="author">
                    
                        <a href="https://www.stltoday.com/users/profile/phalfacre">
                        Paul Halfacre
                        </a>
                    
                </span></li>
        
        
            <li class="visible-print">
        <time datetime="2022-12-22T16:50:00-06:00" class="tnt-date asset-date text-muted">
            Dec 22, 2022
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2022-12-22T16:50:00-06:00" class="tnt-date asset-date text-muted">20 min ago</time></li>
        
        
            <li class="hidden-print"><a href="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html?mode=comments" class="cm">
            <span class="fas tnt-comments"></span> 
            <span id="openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-default" twt-comment-count="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" twt-article-id="f6aec1ca-8248-11ed-b39f-0362ef716cce">0</span> 
        </a>
        <script type="text/javascript">
            fetch("https://open-api.spot.im/v1/messages-count?spot_id=sp_omoe7asV&posts_ids=f6aec1ca-8248-11ed-b39f-0362ef716cce")
                .then(function(response) {
                    return response.json();
                })
                .then(function(openWeb) {
                    if (openWeb && openWeb.messages_count) {
                        document.getElementById("openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-default").innerHTML = openWeb.messages_count['f6aec1ca-8248-11ed-b39f-0362ef716cce'];
                    }
                });
        </script></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-12-22T16:50:00-06:00">
    <meta itemprop="datePublished" content="2022-12-22T16:50:00-06:00">
    <meta itemprop="dateModified" content="2022-12-22T16:50:00-06:00">
</header></div></div>
    
    <div id="asset-content" data-asset-uuid="f6aec1ca-8248-11ed-b39f-0362ef716cce">
        
        <div class="lee-text-row">
            <div itemprop="articleBody" id="article-body" class="lee-track-in-article asset-content ">
               <div id="tncms-region-asset_content_top_site" class="tncms-region hidden-print"></div><div id="tncms-region-article_top" class="tncms-region hidden-print"><div id="tncms-block-1244349" class="tncms-block"><div data-placeholder="true" data-test="top-of-article"></div></div></div><div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1239471" class="tncms-block"><div data-placeholder="true" data-test="top-of-article-content"></div></div></div><div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&via=STLhssports&url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.stltoday.com/tncms/asset/editorial/f6aec1ca-8248-11ed-b39f-0362ef716cce" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSt.%20Louis%20Post-Dispatch%5D%20Mary%20McKenzie%2C%20freshman%2C%20Cor%20Jesu&body=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f6aec1ca-8248-11ed-b39f-0362ef716cce"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link copy">
                <button
                    class="copy btn-link"
                    onclick="copyLink('https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html', '[data-copy-inline-f6aec1ca-8248-11ed-b39f-0362ef716cce]')"
                    data-container="body"
                    data-toggle="manual"
                    data-placement="top"
                    data-content="Article link copied to clipboard"
                    data-copy-inline-f6aec1ca-8248-11ed-b39f-0362ef716cce
                >
                    <span class="tnt-stack" title="Copy article link to clipboard" >
                        
                        <i class="fas tnt-copy tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Copy article link</span>
                </button>
            </li><li class="social-share-link sv">
        <a class="save-list-f6aec1ca-8248-11ed-b39f-0362ef716cce-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f6aec1ca-8248-11ed-b39f-0362ef716cce" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f6aec1ca-8248-11ed-b39f-0362ef716cce" class="save-list-f6aec1ca-8248-11ed-b39f-0362ef716cce-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f6aec1ca-8248-11ed-b39f-0362ef716cce" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
<div class="trinityAudioPlaceholder tnt-text-to-speach subscriber-hide hidden-print"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1245342" class="tncms-block"></div></div><div class="lee-article-text first-p"><p>Finished no lower than seventh place in eight meets in her first season, capped by a seventh-place showing in Class 5 state meet that helped Chargers finish fourth in team standings. Runner-up in two meets and third at Class 5 District 1 meet in season-best 18:30.4.</p></div><div class="clearfix"></div>
    <div class="trinity-skip-it"><div class="asset-tagline text-muted"><!-- tagline suppressed in site component --></div><a id="lee-comments-area" name="comments" style="display:block; margin-top: 40px;"></a><div data-spotim-module="pitc"></div>
            <script>
                var openWebLoaded = false;
                var throttledOpenWeb = throttleFunction(function(){
                    if(!openWebLoaded){
                        openWebLoaded = __tnt.elementOnScreen('#lee-comments-area');
                        if(openWebLoaded){
                            var s = document.createElement('script');
                            s.setAttribute('src', 'https://launcher.spot.im/spot/sp_omoe7asV');
                            s.setAttribute('data-spotim-module', 'spotim-launcher');
                            s.setAttribute('data-post-id', 'homepage');
                            s.setAttribute('data-spotim-autorun', 'false');
                            document.body.appendChild(s);
                            window.removeEventListener('scroll', throttledOpenWeb);
                        }
                    }   
                }, 100);
                window.addEventListener('scroll', throttledOpenWeb);
            </script><div class="text-center margin-bottom hidden-print"><a href="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html?mode=comments" class="btn btn-primary btn-lg">
            <span class="fas tnt-comments"></span> 
            <span id="openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-bottom" twt-comment-count="https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" twt-article-id="f6aec1ca-8248-11ed-b39f-0362ef716cce">0</span> Comments
        </a>
        <script type="text/javascript">
            fetch("https://open-api.spot.im/v1/messages-count?spot_id=sp_omoe7asV&posts_ids=f6aec1ca-8248-11ed-b39f-0362ef716cce")
                .then(function(response) {
                    return response.json();
                })
                .then(function(openWeb) {
                    if (openWeb && openWeb.messages_count) {
                        document.getElementById("openWeb-count-f6aec1ca-8248-11ed-b39f-0362ef716cce-bottom").innerHTML = openWeb.messages_count['f6aec1ca-8248-11ed-b39f-0362ef716cce'];
                    }
                });
        </script></div>
    
<div class="asset-tags hidden-print">
            <h4>Tags</h4>
            <ul class="list-inline"><li>
                <a href="/search/?k=%22prep-sports%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-prep-sports label label-default" data-tncms-track-dmp='search: prep-sports'>Prep-sports</a>
            </li> <li>
                <a href="/search/?k=%22meet%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-meet label label-default" data-tncms-track-dmp='search: meet'>Meet</a>
            </li> <li>
                <a href="/search/?k=%22finish%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-finish label label-default" data-tncms-track-dmp='search: finish'>Finish</a>
            </li> <li>
                <a href="/search/?k=%22sport%22&t=article,collection,video,youtube&l=25&display=topic#tncms-source=keyword" class="tag-sport label label-default" data-tncms-track-dmp='search: sport'>Sport</a>
            </li> </ul>
        </div><style>
            #lee-rev-content { margin:0 -5px; }
            #lee-rev-content h3 {
                font-family: inherit!important;
                font-weight: 700!important;
                border-left: 8px solid var(--lee-blox-link-color);
                text-indent: 7px;
                font-size: 24px!important;
                line-height: 24px;
            }
            #lee-rev-content .rc-provider { 
                font-family: inherit!important; 
            }
            #lee-rev-content h4 { 
                line-height: 24px!important;
                font-family: "serif-ds",Times,"Times New Roman",serif!important; 
                margin-top: 10px!important;
            }
            @media (max-width: 991px) {
                #lee-rev-content h3 {
                    font-size: 18px!important;
                    line-height: 18px;
                }
            }
        </style>
        <div id="lee-rev-content">
            <div id="rc-widget-df962e" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="269488"></div>
            <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer></script>
        </div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-1244232" class="tncms-block"></div></div><div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div><style>
            #pu-email-form-email-preps-article {
                clear: both;
                
                    background-color: #fff;
                
                
                
                    color: #222;
                
                background-position: bottom;
                background-repeat: no-repeat;
                padding: 15px 0 20px;
                margin-bottom: 40px;
                border-top: 4px solid rgba(0,0,0,.8);
                border-bottom: 1px solid rgba(0,0,0,.2);
                
            }
            #pu-email-form-email-preps-article,
            #pu-email-form-email-preps-article p {
                font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", Helvetica, Arial, sans-serif, "Apple Color Emoji", "Segoe UI Emoji", "Segoe UI Symbol";
            }
            #pu-email-form-email-preps-article h2 {
                font-size: 24px;
                margin: 15px 0 5px 0;
                font-family: "serif-ds", Times, "Times New Roman", serif; 
            }
            #pu-email-form-email-preps-article .lead { 
                margin-bottom: 5px; 
            }
            #pu-email-form-email-preps-article .email-desc {
                font-size: 16px;
                line-height: 20px;
                margin-bottom: 5px;
                opacity: 0.7;
            }
            #pu-email-form-email-preps-article form {
                padding: 10px 30px 5px 30px;
            }
            #pu-email-form-email-preps-article .disclaimer {
                opacity: 0.5;
                margin-bottom: 0;
                line-height: 100%;
            }
            #pu-email-form-email-preps-article .disclaimer a {
                color: #222;
                text-decoration: underline;
            }
            #pu-email-form-email-preps-article .email-hammer {
                
                    border-bottom: 3px solid #222;
                
                opacity: .5;
                display: inline-block;
                padding: 0 10px 5px 10px;
                margin-bottom: -5px;
                font-size: 16px;
            }
            @media (max-width: 991px) {
                #pu-email-form-email-preps-article form {
                    padding: 10px 0 5px 0;
                }
            }
        </style>
        <div id="pu-email-form-email-preps-article" class="p402_hide hidden-print"><div class="header-image margin-bottom">
                    <img class="img-responsive" src="https://www.stltoday.com/tncms/media/high_school_sports_header/" alt="">
                </div><div class="text-center"><p class="email-desc">STLHighSchoolSports.com is the most comprehensive source of stats, scores and stories from any and all area high schools.</p></div>

            <div id="email-error-email-preps-article" class="alert alert-danger text-center margin-top" role="alert" style="display:none"></div>
            <div id="email-success-email-preps-article" class="alert alert-success text-center margin-top" role="alert" style="display:none"></div>

            <form class="pu-form" action="https://leeaws.com/postup/subscribe/" method="post" target="_blank">
                <input name="return" type="hidden" value="https://stltoday.com/newsletters/thank-you/#tracking-source=preps&ir=true">
                <input id="pu-list-email-preps-article" name="subscribe[]" type="hidden" value="874">
                <input class="hide" id="hp-email-preps-article" name="phone" type="text">
                
                <div class="form-group">
                    <div class="input-group email-input ">
                        <input id="pu-email-email-preps-article" type="email" name="email" class="form-control" required placeholder="Email Address">
                        <span class="input-group-btn">
                            <button id="pu-btn-email-preps-article" type="submit" class="btn btn-primary">Sign up!</button>
                        </span>
                    </div>
                </div>
                <div id="x-email-lists"></div>
                <div class="disclaimer text-center">
                    
                        <small>* I understand and agree that registration on or use of this site constitutes agreement to its user agreement and <a href="/privacy/" target="_blank">privacy policy</a>.</small>
                    
                </div>
                
            </form> 
        </div>
        <script>
            jQuery(document).ready(function($){
                
                $('#pu-email-form-email-preps-article .pu-form').submit(function(e){
                    if( $('#hp-email-preps-article').val() === '') {
                        $('#hp-email-preps-article').attr('disabled', 'disabled');
                        $('#pu-btn-email-preps-article').attr('disabled', 'disabled');
                        $.ajax({  
                            type: 'GET',        
                            url: 'https://leeaws.com/postup/subscribe/',
                            data: {
                                'subscribe[]': $('#pu-list-email-preps-article').val(),
                                'email': $('#pu-email-email-preps-article').val(),
                                'notify': Cookies.get('lee_pu_notify') ? '' : 'true',
                            }, 
                            dataType: 'jsonp'
                            
                        }).done(function(result){
                            if (result.status && result.status === 'error') {
                                $('#email-error-email-preps-article').html('<strong>An error occured.</strong><br>' + result.data.message).fadeIn();
                                $('#pu-btn-email-preps-article').attr('disabled', false);
                                
                            } else if(result.subscribed) {
                                $('#email-success-email-preps-article').html('<strong>Thank you!</strong><br>' + result.email + ' has been subscribed.').fadeIn();
                                $('#pu-email-form-email-preps-article .pu-form').fadeOut();
                                Cookies.set('lee_pu_notify', 'true', {path:'/'});
                                
                                __tnt.trackEvent({
                                    'category': 'newsletter-widget',
                                    'action': 'submit',
                                    'label': 'email-preps-article',
                                    'value': 1
                               });
                            }
                            
                        }).fail(function(){
                            $('#email-error-email-preps-article').html('<strong>An error occured.</strong><br> Please try again later').fadeIn();
                            $('#pu-btn-email-preps-article').attr('disabled', false);
                        });
                        
                        e.preventDefault();
                    }
                    return false;
                });
            });
        </script><div class="asset-author">
                <article class="clearfix card author  card-author-fa4aa9be-ce14-11e6-b397-db2e5928c384">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.stltoday.com/users/profile/phalfacre" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="phalfacre" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/avatars/f/a4/aa9/fa4aa9be-ce14-11e6-b397-db2e5928c384.52d61cb03d312b8e72eb1f0edffa2009.png?_dc=1483414921" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.stltoday.com/users/profile/phalfacre" rel="author" class="tnt-user-profile-link tnt-user-name">Paul Halfacre</a>
                                </h4>
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="https://twitter.com/pHalfacre_STL" title="Twitter" target="_blank" rel="noopener">
                    <span class="sr-only">Author twitter</span>
                    <span class="tnt-stack">
                       
                       <i class="fab tnt-twitter tnt-stack-1x "></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="mailto:phalfacre@stltoday.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x "></i>
                    </span>
                </a>
            </li></ul><div class="followed-notify-link hidden-print"><button id="follow-author-fa4aa9be-ce14-11e6-b397-db2e5928c384" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=fa4aa9be-ce14-11e6-b397-db2e5928c384&amp;s=start_time&amp;sd=desc" data-subject="Paul Halfacre" data-description="Whenever Paul Halfacre posts new content, you'll get an email delivered to your inbox with a link." data-name="Paul Halfacre notification" data-author-id="fa4aa9be-ce14-11e6-b397-db2e5928c384" data-user-url="https://www.stltoday.com/users/"><i class="fas tnt-star"></i> Follow Paul Halfacre
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" data-tncms-track-dmp='is_followed_notifications_user'>
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.stltoday.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.stltoday.com/users/login/?referer_url=https%3A%2F%2Fwww.stltoday.com%2Fsports%2Fhigh-school%2Fall-metro%2Fgirls-cross-country%2Fmary-mckenzie-freshman-cor-jesu%2Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.stltoday.com/users/signup/?referer_url=https%253A%252F%252Fwww.stltoday.com%252Fsports%252Fhigh-school%252Fall-metro%252Fgirls-cross-country%252Fmary-mckenzie-freshman-cor-jesu%252Farticle_f6aec1ca-8248-11ed-b39f-0362ef716cce.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
            </div></div>
            </div>
        </div>
    </div>
    
    <div id="article-related-bottom-container" class="hidden-print">
        <div class="lee-text-row"><div id="tncms-region-article_aside_top" class="tncms-region hidden-print"></div>
            <div id="article-related-bottom" class="lee-track-article-related-bottom card-compact no-lead-mobile"><div id="article-bottom-related-title" class="style-title hide">
                    <div class="block-title emphasis-h3">
                        <div class="block-title-inner">
                            <h3>Related to this story</h3>
                        </div>
                    </div>
                </div><article id="card-summary-9f3259a8-8247-11ed-9079-8341e049157e" class="tnt-asset-type-collection clearfix card summary has-image image-left  letterbox-style-default  tnt-section-sports tnt-sub-section-high-school tnt-sub-section-all-metro tnt-sub-section-girls-cross-country">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-9f3259a8-8247-11ed-9079-8341e049157e media-preview collection-asset " data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/sports/high-school/all-metro/girls-cross-country/2022-all-metro-girls-cross-country-third-team/collection_9f3259a8-8247-11ed-9079-8341e049157e.html" class="tnt-asset-link"  aria-label="2022 All-Metro girls cross country third team">
                
                
                    <div class="asset-icon"><span class="lee-icon collection"><i class="far tnt-copy tnt-fw" title="Collection"></i></span></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="2022 All-Metro girls cross country third team"
                            class="img-responsive lazyload full default"
                            width="500"
                            height="281"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=150%2C84&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=225%2C127&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/assets/v3/editorial/9/f3/9f3259a8-8247-11ed-9079-8341e049157e/5c06c4c0c892e.preview.png?crop=500%2C281%2C0%2C109&resize=500%2C281&order=crop%2Cresize 540w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/high-school/all-metro/girls-cross-country/2022-all-metro-girls-cross-country-third-team/collection_9f3259a8-8247-11ed-9079-8341e049157e.html" class="tnt-asset-link" aria-label="2022 All-Metro girls cross country third team">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            2022 All-Metro girls cross country third team</a></h4></div>
    
                    
                    
                    
                    
                        
                        
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
            
            <div class="lee-track-article-aside-bottom"><div id="tncms-region-article_aside_bottom" class="tncms-region hidden-print"></div></div>
            
            <div class="lee-track-article-bottom">
                <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1245861" class="tncms-block"></div></div>
            </div>
        </div>
    </div>
</article><div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    
    <div id="global-modal" class="modal fade" tabindex="-1" role="dialog">
        <div class="modal-dialog modal-lg" role="document">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                </div>
                <div id="global-modal-body" class="modal-body"></div>
            </div>
        </div>
    </div>
    
    <div id="site-footer-container" class="hidden-print">
        <footer id="site-footer" class="container">
            
            <div class="row">
                <div id="footer-col-one" class="col-md-4 col-sm-4">
                    <div class="logo">
                        <a href="/sports/high-school/"><img alt="STLtoday.com" src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/custom/image/e56481d2-7305-11ec-a3a1-731d51cf7164.png"></a>
                    </div><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1244178" class="tncms-block"><section id="block-1244178" class="block emphasis-h5   " >
    <div class=""><ul class="card headline-list bullet-disc"><li class="">
            <span class="tnt-headline ">
        
             <a href="http://www.stltoday.com/" class="tnt-asset-link" aria-label="STLtoday.com">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            STLtoday.com</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="http://www.stltoday.com/sports/high-school/coaches/contact-us/article_ce6ce2d8-441f-11e0-a3dd-00127992bc8b.html" class="tnt-asset-link" aria-label="Contact STLHIGHSCHOOLSPORTS.COM">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            Contact STLHIGHSCHOOLSPORTS.COM</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="http://stats.stlhighschoolsports.com/sports/schedules/" class="tnt-asset-link" aria-label="Scoreboard">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            Scoreboard</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="http://stats.stlhighschoolsports.com/sports/mobile/leaders.html" class="tnt-asset-link" aria-label="Leaders">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            Leaders</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="http://www.stltoday.com/sports/high-school/all-metro/all-metro-teams/collection_88114c4c-7390-11e1-8c19-0019bb30f31a.html" class="tnt-asset-link" aria-label="All-Metro">
        <span class="premium-asset-icon-disabled" data-suppressed="in site"></span>

        
            All-Metro</a></span>
        </li></ul></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" aria-label="navigation"></ul></div></div><div id="footer-col-two" class="col-md-4 col-sm-4">
                    <div class="block-title">
                        <div class="block-title-inner">
                            <h4>Sites &amp; Partners</h4>
                        </div>
                    </div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-apps"  href="/apps" ><span class="nav-label">Apps</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-archives"  href="/news/archives/" ><span class="nav-label">Archives</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/events/" ><span class="nav-label">Calendar</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-chats"  href="/chats/" ><span class="nav-label">Chats</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-comics-games"  href="https://www.stltoday.com/members-only/enjoy-these-comics-exclusively-for-subscribers/html_ad15e9a0-40a2-5dfd-9b83-25382655cb93.html?amu=/explore/list"  data-new-window="true"><span class="nav-label">Comics & games</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-contests"  href="/contests/" ><span class="nav-label">Contests</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition/" ><span class="nav-label">E-edition</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-forums"  href="/forums/" ><span class="nav-label">Forums</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-newsletters"  href="/newsletters/" ><span class="nav-label">Newsletters</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-our-events"  href="/ourevents/" ><span class="nav-label">Our events</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-press-releases"  href="/pr/business/" ><span class="nav-label">Press releases</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" ><span class="nav-label">Online Features </span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-submit-an-event"  href="https://new.evvnt.com/?with_navbar&amp;partner=THESTLOUISPOSTDISPATCH&amp;partner_name=St.%20Louis%20Post-Dispatch"  data-new-window="true"><span class="nav-label">Submit an event</span>
                    
                </a></li></ul></div></div>
                <div id="footer-col-three" class="col-md-4 col-sm-4">
                    <div class="block-title">
                        <div class="block-title-inner">
                            <h4>Services</h4>
                        </div>
                    </div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" aria-label="navigation"><li>
                <a class="nav-link  tnt-section-advertise-with-us"  href="/help/advertise-with-us/" ><span class="nav-label">Advertise with us</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-autos"  href="/autos" ><span class="nav-label">Autos</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/ads/" ><span class="nav-label">Classifieds</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="https://www.stltoday.com/help/contact-us/"  data-new-window="true"><span class="nav-label">Contact us</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-homes"  href="/homes/" ><span class="nav-label">Homes</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="/jobs/" ><span class="nav-label">Jobs</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-reprint-permissions"  href="/help/reprints-and-permissions/" ><span class="nav-label">Reprint Permissions</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-site-help"  href="/help/" ><span class="nav-label">Site help</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-st-louis-best-bridal"  href="https://www.stltoday.com/lifestyles/bestbridal/contact-st-louis-best-bridal/article_dfaf4408-1310-11eb-85f7-e3a1047f624d.html?utm_campaign=snd-autopilot&amp;utm_medium=social&amp;utm_source=facebook_St._Louis_Best_Bridal&amp;fbclid=IwAR1QhcrcB-nioyxSq_CR5Q6QVw77rWaGl"  data-new-window="true"><span class="nav-label">St. Louis Best Bridal</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-subscriber-services"  href="/help/subscriber-services/" ><span class="nav-label">Subscriber services</span>
                    
                </a></li><li>
                <a class="nav-link  tnt-section-work-here"  href="http://lee.net/careers/opportunities/?utm_source=newspaper&amp;utm_medium=blox&amp;utm_campaign=workhere"  data-new-window="true"><span class="nav-label">Work here</span>
                    
                </a></li></ul></div></div></div>
            
        </footer>

        <div id="site-copyright-container" class="container">
            <div id="site-copyright" class="row">
                <div class="col-md-7 copyright-left">
                    <span class="text">
                        &copy; Copyright 2022 
                        <a href="/">St. Louis Post-Dispatch</a>, 901 N. 10th St. St. Louis, MO 63101
                    </span>
                    <span class="links">
                        <span class="sep">|</span>
                        <a href="/terms/">Terms of Use</a>
                        <span class="sep">|</span>
                        <a href="/privacy/">Privacy Policy</a>
                        <span class="sep">|</span>
                        <a href="/privacy/#ccpa">Do Not Sell My Info</a>
                        <span class="sep">|</span>
                            <a onclick="window.Osano.cm.showDrawer('osano-cm-dom-info-dialog-open');" style="cursor:pointer">Cookie Preferences</a>
                        </span>
                </div>
                <div class="col-md-5 copyright-right">
                    <span class="text">
                        Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.
                    </span>
                </div>
            </div>
        </div>
    </div>
    
    </div><!-- / offcanvas close  -->
    <div id="notification-panel" class="notify-panel notify-panel-from-right">
            <template>
                <div class="notification-item">
                    <a href="{{url}}" target="_blank"></a>
                    <div class="notification-item-card">
                        <div class="notification-item-image"><img src="{{image}}"></div>
                        <div class="notification-item-content">
                            <div class="notification-item-header">{{title}}</div>
                            <div class="notification-item-summary">{{summary}}</div>
                        </div>
                    </div>
                    <div class="notification-item-dismiss">
                        <i class="fas tnt-times tnt-fw"></i>
                    </div>
                </div>
            </template>
            <div class="notify-panel-container">
                <div class="notify-panel-header">
                    <div class="notify-panel-close"><i class="fas tnt-times tnt-fw"></i></div>
                    <div class="notify-panel-nav" role="tablist">
                        <ul>
                            <li class="active" role="presentation"><a href="#notify-panel-content" role="tab" data-toggle="tab">Notifications</a></li>
                            <li role="presentation"><a href="#notify-panel-settings" role="tab" data-toggle="tab">Settings</a></li>
                        </ul>
                    </div>
                </div>
                <div class="tab-content">
                    <div id="notify-panel-content" class="tab-pane active" role="tabpanel">
                        <div class="notify-panel-content-items"></div>
                        <div class="notify-panel-content-no-items" style="display:none;">You don't have any notifications.</div>
                    </div>
                    <div id="notify-panel-settings" class="tab-pane" role="tabpanel">
                        <div class="notify-panel-settings-promo">
                            <p>Get up-to-the-minute news sent straight to your device.</p>
                        </div>
                        
                        <h5>Topics</h5>
                        
                            <div class="topic-container" data-name="breaking">
                                <h4>Breaking News</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-breaking" class="switch-input" title="topic-breaking" name="topic-breaking" data-topic="breaking" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="alert">
                                <h4>Trending</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-alert" class="switch-input" title="topic-alert" name="topic-alert" data-topic="alert" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="natl-news">
                                <h4>National News</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-natl-news" class="switch-input" title="topic-natl-news" name="topic-natl-news" data-topic="natl-news" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="cardinals">
                                <h4>News</h4>
                                <label class="switch-label">
                                    <span class="sr-only">Subscribe</span>
                                    <input id="topic-cardinals" class="switch-input" title="topic-cardinals" name="topic-cardinals" data-topic="cardinals" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                        
                        <div class="notify-panel-settings-error alert alert-danger" style="display:none; opacity:0;"></div>
                        <div class="notify-panel-settings-success alert alert-success" style="display:none; opacity:0;"></div>
                    </div>
                </div>
            </div>
        </div>
    
    <!-- / site-container close -->
    </div>
    
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("f6aec1ca-8248-11ed-b39f-0362ef716cce")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc6894.add('act', dmpData);_cc6894.bcp();
            });
        });
    
    </script>
    
    
<script src="https://tagan.adlightning.com/leeenterprises/op.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/lee_ds_v3/resources/scripts/userstitch.load.js?_dc=1671747506"></script>
<script>/*<![CDATA[*/ (function(){
        try {
            var oStitch = UserStitch.getManager({
                debugLog: console.debug,
                minimumVisits: 2,
                apiKey: '39b4d123-57cc-4da6-a0c0-443bfdedc249',
                });
              
            
            if (TNCMS.User && TNCMS.User.isLoggedIn()) {
                oStitch.profile.addIdentifier(
                    'eh256', TNCMS.User.getClaim('user', 'eml').sha256
                );
            }
            
            
            oStitch.profile.addIdentifierByLocalStorage('mpid', 'mparticle.mpid');
            window.UserStitchID = oStitch.profile.masterId;

            if(window.UserStitchID && window.localStorage){
                window.localStorage.setItem('_us_master_id', window.UserStitchID);
                __tnt.log('UserStitch ID: ' + window.UserStitchID);
            }
        } catch(oError) {
            __tnt.log('UserStitch warning: ' + oError);
        }
    })(); /*]]>*/</script>
<script>/*<![CDATA[*/ /* __STL.register("site/user","user.js?_dc=1628288341"); */ /*]]>*/</script>
<script>/*<![CDATA[*/ /* __STL.register("jquery/jquery.min","jquery.min.d6d18fcf88750a16d256e72626e676a6.js"); */ /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.log("[SITE] version=2.0.1.24"); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.log({"vendor":"dfp_premium","id":"fixed-impact-top","pos":"fixed-impact-top, atf","include_domain":"stltoday.com","size":"[2,1]","index_slug":"homepage","url":"\/sports\/high-school\/all-metro\/girls-cross-country","_macro":"ads_tag"}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ __tnt.log({"vendor":"dfp_premium","id":"fixed-leaderboard-top","pos":"fixed-leaderboard-top, atf","include_domain":"stltoday.com","size":"[[970,250],[970,90],[728,90]]","not_mobile":true,"overline":null,"index_slug":"homepage","url":"\/sports\/high-school\/all-metro\/girls-cross-country","ppid_ad":true,"_macro":"ads_tag"}); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.log({"vendor":"dfp_premium","id":"fixed-leaderboard-top-tablet","pos":"fixed-leaderboard-top, atf","include_domain":"stltoday.com","size":"[728,90]","not_mobile":true,"overline":null,"index_slug":"homepage","url":"\/sports\/high-school\/all-metro\/girls-cross-country","ppid_ad":true,"_macro":"ads_tag"}); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.log({"vendor":"dfp_premium","id":"fixed-leaderboard-top","pos":"fixed-leaderboard-top, atf","include_domain":"stltoday.com","size":"[[320,50],[300,50]]","mobile":true,"overline":null,"index_slug":"homepage","url":"\/sports\/high-school\/all-metro\/girls-cross-country","ppid_ad":true,"_macro":"ads_tag"}); /*]]>*/</script>
<script src="https://assets.revcontent.com/master/delivery.js" class=" first-p"></script>
<script>/*<![CDATA[*/ 
                    /* Copy url to clipboard */
                    function copyLink(url, copyTarget) {
                        /* Populate clipboard */
                        navigator.clipboard.writeText(url);
                        
                        /* Bootstrap popover */
                         $(copyTarget).popover().popover("show").prop("disabled", true);
                        
                        /* Hide popover after timeout */
                        setTimeout(
                            function() {
                               $(copyTarget).popover("hide").popover("destroy").prop("disabled", false);
                            }, 2000);
                    } /*]]>*/</script>
<script>/*<![CDATA[*/ (function () {
                // Content to be read
                const textSelector = "#article-body";
                
                if (window.TRINITY_PLAYER && TRINITY_PLAYER.players["article-body-f6aec1ca-8248-11ed-b39f-0362ef716cce"]) {
                    TRINITY_PLAYER.api.createPlayer("article-body-f6aec1ca-8248-11ed-b39f-0362ef716cce");
                } else {
                    var js = document.createElement("script");
                    js.setAttribute("data-player-id", "article-body-f6aec1ca-8248-11ed-b39f-0362ef716cce");
                    js.src = "https://trinitymedia.ai/player/trinity/2900003117/?pageURL=https://www.stltoday.com/sports/high-school/all-metro/girls-cross-country/mary-mckenzie-freshman-cor-jesu/article_f6aec1ca-8248-11ed-b39f-0362ef716cce.html&poweredBy&partner=Flex&FAB=1&textSelector=" + encodeURIComponent(btoa(textSelector));
                    document.body.appendChild(js);
                }
            })(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    jQuery('#article-bottom-related-title').removeClass('hide'); /*]]>*/</script>
<script>/*<![CDATA[*/ function messagingCallback(oPayload) {
                __tnt.notify({
                    title: oPayload.title,
                    message: oPayload.body,
                    url: oPayload.url,
                    image: oPayload.icon,
                    duration: 6000,
                    utm: {
                        'utm_source':'BLOX Broadcast',
                        'utm_campaign':'Push Notification',
                        'utm_medium':'referral',
                        'utm_content':'in-page notification'
                    }
                }).showNotification();
            } /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc6894.add('act', serviceData);_cc6894.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc6894.add('act', dmpData);_cc6894.bcp();
                    }
                }
            }
         /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/leetemplates.com/content/tncms/live/global/resources/scripts/dfp.floor.js?_dc=122217"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/pb-config/stltoday.com.js?_dc=1671001230"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/stltoday.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/dfp.lazy.pbjs.js?_dc=1671001230"></script></body>
</html>